1

I have an HP Probook 455 G2 with a Realtek RTL8723BE wireless card. Restarting the network manager doesn't do anything. The Probook also has a hard button to toggle the wireless off and on. I've checked that as well. It doesn't do anything. When I check wireless from the tool tray icon no wireless access points show up.

This is a fix I've used before, which I found on Stack Exchange. Up until 18.04 I was able to follow the instructions in Stack Exchange's answer to this question here - How do I get a Realtek RTL8723BE wireless card to work?. That fix worked very well, but I'm being blocked on the newest LTS.

I cannot use these instructions with 18.04 because of apt-secure. Can you help me either get around apt-secure so I can add the repository or help me get the card to work in another way? This is what I get when I try to add the repository in Bionic Beaver: .....

Err:28 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu Xenial Release    
  404  Not Found [IP: 91.189.95.83 80]
Err:29 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release    
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done                       
E: The repository 'http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu Xenial Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Here is the information on my card:

lshw -C network
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 10
       serial: (redacted)
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=10.1.105.62 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:35 ioport:4000(size=256) memory:d5804000-d5804fff memory:d5800000-d5803fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlo1
       version: 00
       serial: (redacted)
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-20-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:40 ioport:3000(size=256) memory:d4800000-d4803fff

Any advice you can give me would be appreciated.

Thank you,

  • I have same problem with my HP latop. I tried those step and i think the process is run as the description above. After i finisih the step then i restarted my laptop. The pop up show which indicate that the installation is crash. Do you have any idea what is going on? I have similar laptop specs. I used to change the antenna setting by give command in terminal below: sudo modprobe -rv rtl8723be sudo modprobe -v rtl8723be ant_sel=1 It was successful in ubuntu 16.04. But those command doesnt work in my ubuntu 18.04. I confused what is the real problem in ubuntu 18? Is there any solution to solve – rasdidin Aug 28 '18 at 14:11
0

I was able to answer my own question. I should have taken more time to think through what the ppa was doing in the first place. Here are the steps:

  1. Go to the the webpage: https://launchpad.net/~hanipouspilot/+archive/ubuntu/rtlwifi/+packages
  2. Expand the arrow to the left of the listed driver: rtl8192eu-dkms - 4.3.1.1.11320.20140505~trusty1
  3. Scroll down to the third driver listed under "Packages" named: rtl8192eu-dkms_4.3.1.1.11320.20140505~trusty1_all.deb (1.0 MiB)
  4. click on it to download it.
  5. change directory in terminal so you are in the same folder as the downloaded deb file and add executable rights with chmod +x rtl8192eu-dkms_4.3.1.1.11320.20140505~trusty1_all.deb
  6. Then run the command sudo dpkg -i rtl8192eu-dkms_4.3.1.1.11320.20140505~trusty1_all.deb (it will produce an error)
  7. Next execute sudo apt --fix-broken install
  8. Then run the command sudo dpkg --configure -a
  9. Now rerun the command sudo dpkg -i rtl8192eu-dkms_4.3.1.1.11320.20140505~trusty1_all.deb this time will it will get a lot further. However it still produces an error.

Even though there were errors when I followed the above steps my card started working. I found my access point and joined it. It is working normally now. I hope this helps anyone having similar issues with the realtek cards.

  • Very mysterious as you have no rtl8192eu device. Weird. – chili555 May 4 '18 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.