7

I recently did a clean install of Ubuntu 18.04. I did this because I was having trouble with my computer not booting on 16.04. At first when I upgraded everything worked fine and booted normally. But recently I haven't been able to login, when I enter my password/ username is just goes in a loop and asks me for the password again. I am using a Dell XPS 13 and doing CTRL+ALT+F1 or any other function key during the login screen doesn't work. So if someone could provide some insight into this, that would be great :).

closed as off-topic by karel, Kevin Bowen, Pilot6, waltinator, Melebius Jun 18 '18 at 13:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – karel, Kevin Bowen, Pilot6, waltinator, Melebius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Did you solve this, happens to me also. – Alexander Zeitler May 14 '18 at 0:02
  • I just ended up doing another clean install, and it's been working ever since. I didn't have anything in there to lose anyways. – Max May 14 '18 at 5:27
2

I solved this problem by removing a bad path from my .bashrc. This problem can be produced by a .bashrc/.bash_profile file that cannot be interpreted correctly.

  • 1
    Explain why this would cause problem described in Q. Explain how to edit files when cannot log in. – xiota Jun 15 '18 at 17:58
  • 1
    The .bashrc file (usually located in the user's home directory) is loaded when a session is started. If there is a syntax error or bad path in the file, the session might not start properly. To check and edit a .bashrc file without being logged in as a user, you can boot into recovery mode and edit the file from the root terminal. For specific instructions, see answers to this related question: askubuntu.com/questions/842085/… – acuriousloop Jun 16 '18 at 19:00
  • @acuriousloop, append correction to the main post text, please ) – isnullxbh Jun 19 '18 at 12:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.