0

after installing Ubuntu 18.04 with minimal installation, I noticed that it boots slowly here is the output of systemd-analyze blame.

     21.048s systemd-journal-flush.service
     19.300s dev-sda7.device
     14.310s plymouth-start.service
     11.883s plymouth-quit-wait.service
     10.579s dev-loop1.device
     10.578s dev-loop0.device
     10.566s dev-loop2.device
     10.566s dev-loop7.device
     10.486s dev-loop3.device
     10.387s dev-loop5.device
     10.352s dev-loop6.device
     10.326s dev-loop8.device
     10.316s dev-loop4.device
     10.288s dev-loop9.device
     10.247s dev-loop10.device
      6.684s NetworkManager-wait-online.service
      5.624s systemd-udevd.service
      5.313s bolt.service
      4.589s snap-gnome\x2d3\x2d26\x2d1604-62.mount
      4.552s snap-gnome\x2dsystem\x2dmonitor-39.mount
      4.536s snap-gnome\x2dsystem\x2dmonitor-36.mount
      4.405s snap-gnome\x2d3\x2d26\x2d1604-59.mount
      4.372s snap-gnome\x2dcalculator-167.mount
      4.350s snap-gnome\x2dcalculator-154.mount
      4.325s snap-gnome\x2dcharacters-86.mount
      4.322s snap-gnome\x2dcharacters-69.mount
      4.111s snapd.service
      3.868s snap-core-4486.mount
      3.452s udisks2.service
      3.405s grub-common.service
      3.163s apport.service
      2.931s networkd-dispatcher.service
      2.689s speech-dispatcher.service
      2.573s networking.service
      2.495s ModemManager.service
      2.493s thermald.service
      2.491s bluetooth.service
      2.478s pppd-dns.service
      2.476s gpu-manager.service
      2.475s rsyslog.service
      2.440s accounts-daemon.service
      2.184s avahi-daemon.service
      2.094s alsa-restore.service
      2.079s systemd-logind.service
      1.881s apparmor.service
      1.786s keyboard-setup.service
      1.740s NetworkManager.service
      1.474s wpa_supplicant.service
      1.110s fwupd.service
      1.097s systemd-backlight@backlight:intel_backlight.service
       917ms systemd-fsck@dev-disk-by\x2duuid-02BB\x2dC6E5.service
       904ms systemd-random-seed.service
       779ms systemd-remount-fs.service
       756ms systemd-tmpfiles-setup-dev.service
       717ms dev-hugepages.mount
       714ms dev-mqueue.mount
       710ms sys-kernel-debug.mount
       616ms systemd-modules-load.service
       573ms systemd-journald.service
       449ms systemd-tmpfiles-setup.service
       426ms systemd-tmpfiles-clean.service
       416ms packagekit.service
       366ms systemd-resolved.service
       323ms snap-gnome\x2dlogs-25.mount
       311ms dns-clean.service
       308ms console-setup.service
       294ms snap-gnome\x2dlogs-31.mount
       275ms ufw.service
       267ms swapfile.swap
       267ms swapfile.swap
       258ms upower.service
       239ms polkit.service
       222ms [email protected]
       220ms gdm.service
       202ms boot-efi.mount
       186ms systemd-timesyncd.service
       168ms systemd-udev-trigger.service
       165ms [email protected]
       141ms setvtrgb.service
       103ms plymouth-read-write.service
       103ms sys-fs-fuse-connections.mount
       102ms sys-kernel-config.mount
        84ms systemd-update-utmp.service
        71ms colord.service
        65ms systemd-sysctl.service
        54ms kmod-static-nodes.service
        30ms rtkit-daemon.service
        21ms systemd-user-sessions.service
        10ms kerneloops.service
         8ms ureadahead-stop.service
         7ms systemd-update-utmp-runlevel.service
         3ms systemd-rfkill.service
         1ms snapd.socket
2
  • I am facing the same issue on Lenovo 320. I have upgraded my laptop. Commented May 5, 2018 at 9:48
  • So we keep waiting :( Commented May 5, 2018 at 15:09

1 Answer 1

0

You have loop devices that are taking forever to mount during boot. Try and see what is mounted as loopback devices by running mount after boot. My bet is that these are snaps (you clearly have snapd installed) and in the event that you have no use for snaps, get rid of them by uninstalling them and uninstalling snapd. It improved boot time in my case.

dev-sda7.device is your root partition. 19 seconds means that your hard disk is slow to activate, and unless you get you a new hard disk, I don't think this can be fixed.

I know most people wouldn't dream of this let alone try it, but you might want to disable plymouth and see if boot time improves in your case. This will remove the graphical boot screen and replace it with scrolling text.

Disable plymouth by editing /etc/default/grub. Find the line GRUB_CMDLINE_LINUX_DEFAULT and remove "splash" so that the line now reads:

GRUB_CMDLINE_LINUX_DEFAULT="quiet video=SVIDEO-1:d"

[Remember to backup your grub file before modifying it. You might want to read this: Disable plymouth to improve boot time.

1
  • thank you for your answer, but my laptop is new and i tried to test my hard driver and it works fine with 100-120Mb/S to read and almost 100 for writing. so the problem sure isn't with the hard driver. I saw the same problem with the same version of my Lenovo ideapad 520 laptop. so do you think i still need to change the hard driver ? anyway disabling plymouth helped much. Commented May 31, 2018 at 11:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .