1

Recently upgraded from Kubuntu 17.10 to Kubuntu 18.04.

In 17.10, KDE Wallet was working as expected. It stored all my wi-fi passwords, SSH passwords, etc.

After the upgrade, it started asking me for wi-fi password and SSH password.

Today, when I accessed Settings -> KDE Wallet, there was no sign of any wallet. When I tried creating a new one, I could not. The program became unresponsive.

When I launched KDE Wallet Manager, there was no wallet. I could not create one. The program became unresponsive.

How do I set things right?

  • Have you tried to launch it from terminal to check error messages? – E_Angel May 4 '18 at 15:20
  • There's no kwallet application! – deshmukh May 4 '18 at 17:25
  • if it installed , open terminal and type first letters from app you want , this case kwa and then press TAB two times , this way is displayed all app that possibly match – E_Angel May 4 '18 at 17:43
1

I had same problem. I made these steps to make it works again (maybe only one was necessary)

  • kill all processes which I found via ps aux | grep kwallet (there was three and I think one of these processes can "lock" wallet opening. Because when I killed it pop up for password appeared)
  • Run update - After upgrade to 18.04 I ran apt update && apt upgrade and it found 3 updates (libpam-kwallet-common, libpam-kwallet4, libpam-kwallet5)
  • Reboot once again - After login I was asked for password into wallet and it looks kwallet working again.

Hope it helps.

Best regards, cr4wen

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.