I have noticed that if I press F10 when on a terminal, Ubuntu or the terminal opens the File Menu. Is there any way to unbind this?

I don't see any entries with F10 on System settings -> Keyboard shortcuts

I want to use function keys in Emacs to debug my code (e.g. F10 triggering gud-step, etc.) when running Emacs within a terminal ( emacs -nw) but at the moment the terminal seems to be capturing my keys.

Update 1:

If I go to Edit -> Keyboard Shortcuts I can disable the option "Enable the menu short key (F10 by default)". So I disabled it. However , the key F10 is still bound to the menu!!

Is there a way to unbind this key other than through the Edit-> Keyboard shortcuts menu? Perhaps there is a configuration text file under etc where I can activate/deactivate keyboard shortcuts?

Update 2:

I also followed all the tricks here and they didn't work. F10 still behaves as an accelerator in the terminal.

This is all on Ubuntu 11.10

Update 3:

Following the suggestions in this link I also tried:

3.1 Adding the following code to ~/.gtkrc-2.0

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"

class * binding "NoKeyboardNavigation"

3.2 Adding the following code to ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
    unbind "<shift>F10"

* {
    gtk-key-bindings: NoKeyboardNavigation

and the problem still persists.

  • gsettings set org.gnome.Terminal.Legacy.Settings menu-accelerator-enabled false
    – unxed
    Commented Mar 13 at 22:10

4 Answers 4


Ubuntu Gnome 16.04 LTS

In terminal, hit Windows (super) key + F10 to open Application menu:

enter image description here

Click Preferences, and untick Enable the menu accelerator key (F10 by default):

enter image description here

  • 2
    Also applicable to 18.04. Commented Nov 29, 2018 at 16:15
  • 1
    And still good in 22.04 :-)
    – Colin
    Commented Jun 21, 2022 at 4:47

If you're using gnome-terminal, go to Edit > Keyboard Shortcuts. There is an option to unbind F10 from the file menu. Unfortunately there doesn't seem to be an option for F11. But note that F11 is a system-wide shortcut for full-screen.

Update: Thanks to James Henstridge for pointing out that there is an option for F11, since it appears on the view menu! Unfortunately OP says this is not working. I am not able to reboot at the moment to determine if it works on my system.

Ok, I found this: https://bbs.archlinux.org/viewtopic.php?pid=1017546#p1017546 . Does that work?

  • Thanks, I just tried it, rebooted the machine, but the key is still bound to the File menu! Really odd, I have just updated my question. Commented Feb 10, 2012 at 23:14
  • 1
    The F11 key is an application shortcut key, and can be unbound from the dialog box you mentioned (under View -> Full Screen). Commented Feb 11, 2012 at 0:30

in my case I had to change the contents of ~/.gtkrc-2.0:

   binding "NoKeyboardNavigation" {
          unbind "<shift>F10"

   class "*" binding "NoKeyboardNavigation"

Please note the double-quotes around the asterisk in the last line! It took me some time to find out that it has to be quoted. :-)

I hope it helps you,

  • for terminator in 12.04 this solution was good only for me. Thx!
    – Regisz
    Commented May 15, 2013 at 11:45

I found that in addition to disabling the F10 menu accelerator key in the gnome-terminal preferences, I also needed to unbind it from Unity.

Using the Compiz Configuration Settings Manager, select Desktop, then Ubuntu Unity Plugin, then in the General tab, then disable the "Key to open the first panel menu".


Not the answer you're looking for? Browse other questions tagged .