After upgrading from Ubuntu MATE 16.04 to 18.04, I can no longer get the network applet in the notification area.

This answer shows how I solved this in 15.04, and this solution survived the upgrades to 15.10 and 16.04, IIRC without any need for further intervention.

On 18.04 this no longer works:

  • ~/.config/autostart/nm-applet.desktop was no longer there, so I copied it back from /etc/xdg/autostart/. The edits described in the original answer no longer apply, so I left the file unchanged. Even after login, the applet does not come back.
  • When I try to launch nm-applet manually from the command line, it just gives me the message Gtk-Message: 13:48:39.885: Failed to load module "topmenu-gtk-module", then exits and no network applet is ever displayed.
  • The notification area, as indicated in this answer, is active—I see the volume applet.
  • If it matters, I have the Traditional panel layout.

Additional information: on another computer (also upgraded to 18.04 from 16.04 but using the Familiar layout) the applet is still there.

What gives?

  • bugs.launchpad.net/ubuntu/+source/network-manager-applet/+bug/… Sounds like this might be this bug, if so might be worth commenting to keep their eyes on it (it's from March 2018, might be good to make sure it's clear this isn't just a beta problem). Interestingly, I'm on a clean install and on my first boot I had the opposite problem! Two NM applets. Rather, I think one was the nm-applet, and the other is part of the "indicator applet complete" stuff which I think is new for 18.04. Anyways, it went away after rebooting and hasn't come back. – mock_blatt May 5 '18 at 4:59

I don’t know what it was, but I was able to get the network applet back by going to System > Preferences > Look and Feel > MATE Tweak, and in Panels, first saving the existing layout, then re-selecting the Familiar layout.

Note that this will delete any customizations (if you’re not ready to part with them, be sure to keep a backup around). However, now I have the notification area with Bluetooth, network, mail, battery and sound icons (previously there was only the sound icon), as well as the combined Settings/Shutdown icon (previously I had the Shutdown icon instead).

Since there have been doubts about this: this solution has also survived multiple reboots.

| improve this answer | |
  • This works, but have to mentioned that it would remove all or any shot icons added to the panel And I'm used to the Traditional layout than the Familiar one – ManZzup Jun 27 '18 at 1:42
  • There's no MATE Tweak in my Look and Feel menu ... – Linas Oct 15 '18 at 4:58
  • 1
    ... so I apt-get installed mate-tweak. I was unable to save; I was forced to choose between fedora/gnome2, which wiped out absolutely everything. Total wipeout. This is a major unrecoverable loss of a dozen applets I'd pain-stakingly tweaked over the years. Very unhappy right now. – Linas Oct 15 '18 at 5:09
  • Man labai gaila… I’ll highlight the fact that this will nuke any existing customizations. – user149408 Oct 16 '18 at 19:34
  • This worked a treat! I've been fiddling trying to sort this for ages to no avail. Lo and behold at my darkest hour, trying to figure out how to connect to an obscure hotel wifi that has a login page from terminal while hotspotting from my phone I stumbled across this answer. Went into Mate Tweak and selected the 'Traditional' Panel layout and boom. Sorted. Thanks mate – theYnot Feb 24 at 8:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.