11

There is a problem with my laptop — jumping cursor. I think the hardware is the source of the problem. Maybe toucpad is just very inaccurate when getting finger coordinates and touching events.

On Ubuntu 14.04 I just set vertical and horizontal hysteresis and high and low finger pressure to make touchpad feel smooth and nice. When I installed 18.04 I found that I can't adjust my touchpad any more (except a few options that are not too helpful in my case).

So, can anybody of you, guys, help me with getting back that beautiful synaptics driver?

  • 1
    run this command: " sudo apt install xserver-xorg-input-synaptics ", after that run this command: " synclient TapButton1=1 TapButton2=3 TapButton3=2" – Ryko May 4 '18 at 11:35
  • Is that enough to switch driver? I tried the answer below and nearly broke my system. Keyboard stopped working. – Zephyr Zephyroff May 4 '18 at 17:16
  • Have you tried both of my commands, This command will not remove any package, so this is not going to break your system. If the above command works for you, then I will tell you the further process. I am just checking if the synaptics driver is working for you. – Ryko May 5 '18 at 6:42
  • Couldn't find synaptics properties. No synaptics driver loaded? – Zephyr Zephyroff May 5 '18 at 17:19
  • Then you have to install synaptic driver. Run this command without quotes "sudo apt install xserver-xorg-input-synaptics". Then after installation run this command without quotes: "synclient TapButton1=1 TapButton2=3 TapButton3=2". – Ryko May 5 '18 at 19:53
12

I had the same problem and basically solved it by following Ryko's advice.

sudo apt install xserver-xorg-input-synaptics

... did the trick. I didn't uninstall libinput like Pilot6 said and libinput is still happily handling my keyboard, etc.

  • It's not working in my case. Probably there is something missed. Some package or configuration. I'm always seeing the same Couldn't find synaptics properties. No synaptics driver loaded?. I don't know how to get rid of this. – Zephyr Zephyroff May 15 '18 at 16:51
  • 2
    Eventually it started working. I installed xserver-xorg-input-synaptics then rebooted the system. And it worked. Thanks! – Zephyr Zephyroff May 17 '18 at 8:33
  • 1
    Make sure to run sudo apt update first to avoid getting an 'Unable to locate package' error - doh! – David Jun 27 '18 at 21:54
  • Thanks a lot!!! This worked for me instantly on my Dell Vostro with Ubuntu 18.04. – Swapnil Rustagi Nov 5 '18 at 11:05
  • This hasn't worked for me. Tried removing and installing and rebooting a number of times. – RjPiston Aug 3 at 3:40
2

If you're running an HWE release (like 18.04.2) then you'll actually want:

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

You don't need to remove any packages, just add this and once it's active you can make adjustments to your taste. (as others have indicated above)

Hint: The suffix "-hwe-18.04" needs to be appended to any pkg that HWE impacts. Read up on HWE and you'll understand why and the scope of the packages impacted.

1

The problem is not necessarily the missing Synaptics drivers, it is more the fact that the libinput driver settings are purposefully left generic so that the user or hardware OEM can adjust them as desired.

Rather than simply uninstalling libinput and installing Synaptics, you can still add Synaptics but to keep everything working you need to provide an "override" by removing/updating references to libinput specifically in relation to your touchpad ONLY and adding in a rule for Synaptics.

A major part of the problem is that there doesn't appear to be any proper GUI tool and few of the hardware OEMs (Dell/HP/Lenovo/etc) provide customized configs optimized to their hardware outside the possible exception of their own preinstalled Ubuntu versions (Dell provides this option at least). I haven't grabbed the latest Dell Ubuntu image and unpacked it to see if they supply any customizations, but it wouldn't surprise me if they did. If not I definitely think it is something they should see about adding, since the XPS13/XPS15 and their business brothers the Precision 55x0 models are amazingly fast running Ubuntu compared to Windows.

This article by Dell has a good start on how to potentially fix the issue (and doesn't necessarily only apply to their systems or their touchpads), https://www.dell.com/support/article/us/en/19/sln308258/precision-xps-ubuntu-general-touchpad-mouse-issue-fix?lang=en

  • 2
    can you give instructions on how to do the override? – jvdh Oct 23 '18 at 14:53
1
can you give instructions on how to do the override? 

The synaptics config file can be copied to /etc/X11/xorg.conf.d and given a higher number than the /usr/share/X11/xorg.conf.d synaptics.conf default. Then the synaptics touchpad driver overrides the libinput touchpad driver by having a higher priority.

There is an option that could be added to libinput.conf to prevent the libinput touchpad driver from being considered. After "MatchIsTouchpad" add:

Option "Ignore" "true"

Check with xinput:

xinput list
xinput --list-props "whatever touchpad from above list"

That will show either the libinput or the synaptics properties if the touchpad is using libinput or synaptics respectively. The synaptics touchpad driver should show output something like this:

Device 'ELAN1300:00 04F3:3057 Touchpad':
Device Enabled (152):   1
Coordinate Transformation Matrix (154): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
Device Accel Profile (280): 1
Device Accel Constant Deceleration (281):   1.000000
Device Accel Adaptive Deceleration (282):   1.000000
Device Accel Velocity Scaling (283):    1.000000
Synaptics Edges (284):  0, 3208, 0, 2210
Synaptics Finger (285): 1, 70, 0
Synaptics Tap Time (286):   180
Synaptics Tap Move (287):   171
Synaptics Tap Durations (288):  180, 180, 100
Synaptics ClickPad (289):   1
Synaptics Middle Button Timeout (290):  0
Synaptics Two-Finger Pressure (291):    282
Synaptics Two-Finger Width (292):   7
Synaptics Scrolling Distance (293): 154, 77
Synaptics Edge Scrolling (294): 0, 0, 0
Synaptics Two-Finger Scrolling (295):   1, 0
Synaptics Move Speed (296): 1.000000, 1.000000, 0.000000, 0.000000
Synaptics Off (297):    0
Synaptics Locked Drags (298):   0
Synaptics Locked Drags Timeout (299):   5000
Synaptics Tap Action (300): 0, 0, 0, 0, 0, 0, 0
Synaptics Click Action (301):   1, 3, 2
Synaptics Circular Scrolling (302): 0
Synaptics Circular Scrolling Distance (303):    0.100000
Synaptics Circular Scrolling Trigger (304): 0
Synaptics Circular Pad (305):   0
Synaptics Palm Detection (306): 1
Synaptics Palm Dimensions (307):    10, 200
Synaptics Coasting Speed (308): 20.000000, 50.000000
Synaptics Pressure Motion (309):    30, 160
Synaptics Pressure Motion Factor (310): 1.000000, 1.000000
Synaptics Grab Event Device (311):  1
Synaptics Gestures (312):   1
Synaptics Capabilities (313):   1, 0, 0, 1, 1, 0, 0
Synaptics Pad Resolution (314): 32, 31
Synaptics Area (315):   0, 0, 0, 0
Synaptics Soft Button Areas (316):  1604, 0, 1800, 0, 0, 0, 0, 0
Synaptics Noise Cancellation (317): 50, 50
Device Product ID (276):    1267, 12375
Device Node (275):  "/dev/input/event15"

The synaptics touchpad driver allows for adjusting many settings when the libinput driver just turns a few things on or off and so is not useful for my touchpad.

  • All this did was disable my touchpad, which leads me to believe that the synaptics drivers aren't even loading. – RjPiston Aug 3 at 3:51
0

I ran into problem after installing synaptics touchpad in ubuntu 18.04. My keyboard stopped working. So, I booted into the system (keyboard was working on login screen), mouse was working properly so I opened my mails from the history (I saved the commands in the mails using my mobile), I copied the following commands with enter (empty line after the commands):

sudo apt install xserver-xorg-input-all xserver-xorg-input-synaptics

This fixed boot the keyboard and mouse. No need to remove libinput or anything else. Reboot and everything is working now.

Note: Save the commands with an empty line using enter at the end of commands. This will help commands to execute directly without pressing enter while copy pasting in terminal, if the keyboard is not working.

-2

You can do it by

sudo apt remove xserver-xorg-input-libinput
sudo apt install xserver-xorg-input-synaptics

But in most cases libinput is better than synaptics. Anyway it's your choice still.

  • 3
    After these operations only touchpad was left working. Keyboard stopped responding. Luckily there was screen keyboard. – Zephyr Zephyroff May 4 '18 at 17:13
  • 5
    Removing xserver-xorg-input-libinput caused my keyboard to stop working too after a reboot and logging in again. Had to log in using Wayland option (instead of X11) then reinstall libinput driver. – David Jun 27 '18 at 22:09
  • 2
    it brokes keyboard input – makerj Aug 17 '18 at 3:34
  • 1
    This worked for me. I think the synaptics driver is much faster, libinput made the touchpad feel sluggish even at max sensitivity. (XPS13) – willbradley Sep 26 '18 at 20:46
  • 1
    Not good to give suggestions where things break. Kindly edit your answer atleast after the negative experiences by people. – ptmdevncoder Dec 9 '18 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.