I recently installed ubuntu 18.04 LTS ,and my laptop is dell vostro 14 3468. But since i updated to 18.04 i can't really use pulse audio equaliser. When i start pulse audio in terminal it says

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

And also my touch pad now sucks, it jumb over frequently, that is annoying. why is ubuntu 18.04 like this. please help.

  • When you copy and paste text from the terminal please include the command you used, not just the output from the command. This allows others to test the exact same way. – WinEunuuchs2Unix May 4 '18 at 10:26

None of the above solutions worked for me, so here is what I found helpful in my case:

cleanup the previous mess:

sudo apt purge pulseaudio-equalizer
sudo add-apt-repository --remove ppa:nilarimogard/webupd8

Install the pulseeffects (equalizer included):

sudo add-apt-repository ppa:mikhailnov/pulseeffects -y
sudo apt update
sudo apt install pulseeffects

Pulseeffects comes with equalizer so there is no need to install the equalizer separately. The above solution works perfectly in case of Ubuntu 18.04 and I found it here https://github.com/wwmm/pulseeffects/wiki/Package-Repositories

  • Wow! This made my computer a complete mobile audio suite for live presentations. Easy to understand if you are related to professional audio. And yes, includes the equalizer, but it is more than just an EQ. Thank you. – Geppettvs D'Constanzo Dec 29 '18 at 18:37
  • this worked for me but i had to reboot the PC after the last command (apt install pulseeffects) to make it work – Riki137 Nov 4 '20 at 14:14

This is how I fixed that on my 18.04 LTS:

I cloned a newer version of pulseaudio-equalizer from github and did the configuration. The way to do that is as follows:

$ cd ~/Desktop && mkdir tmp && cd tmp
$ git clone https://github.com/kernelOfTruth/pulseaudio-equalizer.git
$ cd pulseaudio-equalizer
$ cp -R share/pulseaudio-equalizer/presets/ ~/.config/pulse/
$ cp equalizerrc ~/.config/pulse
$ sudo cp -R share/applications/ share/pulseaudio-equalizer/ /usr/share/
$ sudo cp bin/pulseaudio-equalizer bin/pulseaudio-equalizer-gtk /bin/
$ cd ~/.config/pulse
$ touch ~/.config/pulse/equalizerrc.availablepresets
$ sudo chmod +x /usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py
$ python /usr/share/pulseaudio-equalizer/pulseaudio-equalizer.py

Then at this point just enable the equalizer and apply the settings.

UPDATE: After a while (messing up with audio settings), I discovered that the equalizer never persists (enabling it misbehaved). That took me back to square 1. To resolve that I downloaded pulseeffects and used it to trick pulseaudio-equalizer like this:

$ wget https://launchpad.net/~yunnxx/+archive/ubuntu/gnome3/+files/pulseeffects_1.313entornosgnulinuxenial-1ubuntu1_amd64.deb
$ sudo dpkg -i pulseeffects_1.313entornosgnulinuxenial-1ubuntu1_amd64.deb

Then I:

  1. Launched and enabled equalizer on pulseeffects,
  2. Launched and enabled pulseaudio-equalizer
  3. Exited pulseeffects

NOTE: Pulseeffects doesn't persist. I have no idea how, but it tricks pulseaudio-equalizer to persist. Beats me.

  • Thank you. But please note that share and bin folders must be copied to ~/.config/pulse to avoid errors. – Vladimir Jovanović May 7 '18 at 10:21
  • now i am using pulse effects. it seems a good equaliser, but didint get sound when i change it cnfiguration, sound is coming and going. so i give up on that. last time when i install pulse audio equaliser packages conflicted, and i have to reinstall the ubuntu 18.04. such a drag. very well , thanks – abi jithu May 22 '18 at 7:01

I recently found out that pulseaudio-equalizer is part of the universe repository since Ubuntu 17.04 and the only thing you have to do is to enable the universe repository and you can install the equalizer as sudo apt install pulseaudio-equalizer.

  • 2
    That does not work with 18.04. Did you even try this out? – Paul Benson Aug 25 '18 at 17:16

You can install from Webupd8 PPA repo with following commands for Ubuntu 18.04 based distros. Pref file for priority of PPA's package.

First remove main repo's package.

sudo apt purge pulseaudio-equalizer

After install from PPA

sudo add-apt-repository ppa:nilarimogard/webupd8

echo -e 'Package: pulseaudio-equalizer\nPin: release o=LP-PPA-nilarimogard-webupd8\nPin-Priority: 700' | sudo tee /etc/apt/preferences.d/webupd8.pref

sudo apt-get update

sudo apt-get install pulseaudio-equalizer
  • That's fine for 16.04. This does not work for 18.04. Please stop wasting people's time. – Paul Benson Aug 25 '18 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.