ubuntu with xfce (xubuntu) or lxde (lubuntu) on virtualbox and guest additions installed and clipboard sharing set to bidirectional does not allow plain text to be copied/pasted to/from the virtual and the host system; what else needs to be configured?

note - this is an issue across multiple releases of ubuntu; on some it appears to work partially; I have not found a lubuntu where it works; as if something basic in lubuntu causes copy/paste of plain text to not work

  • what is the host OS?
    – boggy
    May 4, 2018 at 9:30
  • @bogdan host OS is windows 10
    – jmarina
    May 4, 2018 at 9:58
  • Had you installed the guest additions in the guest? Any errors on that?
    – Takkat
    May 4, 2018 at 10:07
  • @Takkat the guest additions installed without errors in the guest, and it is also a new install, with nothing else added, just the base system + guest additions, it is reproducible
    – jmarina
    May 4, 2018 at 10:34
  • @OrganicMarble no the user is not added to the vboxsf group, I just checked using this command: grep vboxsf /etc/group
    – jmarina
    May 4, 2018 at 13:46

1 Answer 1


A variation of this answer worked. First, the intro steps: double-click the VBox_* CD icon on the desktop to mount the guest additions. Then open a terminal, ctrl+alt+t and go to the directory where the virtual CD was mounted: cd /media/your_user_name/VBox_ and press tab to complete the path name.

Then run the linux version: sudo ./VBoxLinuxAdditions.run

Next, to get it working:

Specifically, this fixes it for lubuntu 16.04:

sudo apt-get update
sudo apt-get install virtualbox-guest-x11 xorg-video-abi-20 xserver-xorg-core

if it asks you about keeping a file or installing the new one, press i to select the new one/package maintainer's version;

sudo VBoxClient --clipboard

this fixes it for lubuntu/xubuntu 18.04 - 20.04 and derived variants:

sudo apt-get update
sudo apt-get install virtualbox-guest-x11

if it asks you about keeping a file or installing the new one, press i to select the new one/package maintainer's version;

sudo VBoxClient --clipboard

Note, as raghavan said, that installing virtualbox-guest-x11 package as shown, also resolves the issue where the shared folders are not visible.

And installing this package (and rebooting the virtual machine) also resolves the guest window not autoresizing when the vm window is resized.

This also resolves the issue where paste after reboot no longer works and sudo VBoxClient --clipboard command needs to be repeated. After installing virtualbox-guest-x11, the --clipboard command does not need to be repeated after each reboot.

  • 3
    this has also fixed the problem where i was not able to see the shared folders from host on the VM. believe package virtualbox-guest-x11 was missing earlier.
    – raghavan
    May 31, 2018 at 13:09
  • 1
    These set of 3 commands for 18.04 made my installation unresponsive to mouse click and keyboard entries. I can login, see desktop, see mouse moving, but I cannot click anything. Apr 9, 2019 at 17:34
  • @user1700890 try going to virtualbox settings, USB, and remove filters, if any; normally you add a filter, such as if you want your android device to be visible in virtualbox; but the presence of more than one USB filter, or of an unused filter, can cause this issue, I have seen it also
    – jmarina
    Apr 26, 2019 at 8:59
  • I just did this on lubuntum 16.04 and I got the same result as @user1700890. After reboot the VM is complete unresponsive to keyboard and mouse. Don't know why that happened, but it rendered my VM useless and I will be starting over from a fresh install.
    – Brick
    Sep 10, 2020 at 20:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .