10

When I run the command to update the firmware it states to manually be put in update mode. I've searched for an explanation but can't find anything that helps.

# fwupdmgr -v update
Downloading RQR12.07_B0029 for Unifying [runtime]...
Updating RQR12.07_B0029 on Unifying [runtime]...
Decompressing…         
Device Unifying [runtime] needs to manually be put in update mode

Output from fwupdmgr get-devices:

Unifying [runtime]
  Guid:                 9d131a0c-a606-580f-8eda-80587250b8d6
  UniqueID:             com.logitech.Unifying.RQR12.firmware
  DeviceID:             usb:00:01
  Description:          <p>A Unifying receiver allows you to connect multiple compatible keyboards and mice to a laptop or desktop computer with a single USB receiver. Updating the firmware on your Unifying receiver improves performance, adds new features and fixes security issues.</p>
  Plugin:               unifying
  Flags:                allow-online|supported|needs-bootloader
  DeviceVendor:         Logitech
  Version:              003.000.12003
  VersionBootloader:    BL.0aa.0aa
  Created:              2018-05-04
  AppstreamId:          com.logitech.Unifying.RQR12.firmware
  Summary:              Firmware for the Logitech Unifying receiver
  UpdateDescription:    <p>This release addresses an unencrypted keystroke injection issue known as Bastille security issue #11. The vulnerability is complex to replicate and would require a hacker to be physically close to a target.</p>
  UpdateVersion:        RQR12.07_B0029
  UpdateHash:           d0d33e760ab6eeed6f11b9f9bd7e83820b29e970
  UpdateChecksumKind:   sha1
  License:              Proprietary
  UpdateUri:            https://fwupd.org/downloads/938fec082652c603a1cdafde7cd25d76baadc70d-Logitech-Unifying-RQR12.07_B0029.cab
  UrlHomepage:          http://support.logitech.com/en-us/software/unifying
  Vendor:               Logitech
  Trusted:              none
12

I tested all (probably most) of the solutions that are online. And the solution that worked (I'm using Ubuntu 18.04 Live) is the following:

  1. Remove the apt version of fwupd with

    sudo apt remove fwupd
    

    Because the current repository version of Ubuntu 18.04 seems to be

    client version: 1.0.9
    checkout info: 1.0.9

    This is a problem, because this version yields the following error:

    cannot handle firmware requirement not-child

  2. Replace it with the snap version of fwupd which also (maybe) installs snap, too.

    sudo snap install fwupd --classic
    

    The current snap version on the other hand provides a newer version which works without this complication. Its version is (as of July 2019)

    client version: 1.2.10
    checkout info: 1.2.10

    As of June 2020, the following is valid

    client version: 1.4.3
    daemon version: 1.4.3

  3. With this current version, execute

    fwupdmgr refresh
    
  4. And finally, execute the update

    fwupdmgr update
    
  5. Now test the version with

    fwupdmgr get-devices | grep -A30 "Unifying Receiver" | grep -i "version:"
    

    Its output should be (as of 25.07.2019):

    Current version: RQR12.08_B0030

Update: The version as of June 2020 may be RQR12.10_B0032

| improve this answer | |
  • There is no need to use sudo with fwupdmgr when updating firmware for Unifying Receiver. – jarno Aug 19 '19 at 3:08
  • Look at the end of the page for reference here – jarno Aug 19 '19 at 5:10
1

As suggested here the problem is most likely caused by the version of fwupd being too old and no longer supported. The fix, suggested both on that issue and here is to boot from a live media with a newer version of fwupd and to upgrade using that version. Please see the latter answer for details on how to do that.

[Later Edit]: Even though I tried the above with Ubuntu 18.04 and it updated successfully, after booting back to Ubuntu 16.04 the update was still showing up. I eventually updated the firmware via a Windows machine and the software from here. I am not certain that that is the latest version (as the software did not report the firmware version) but the Ubuntu update did disappear afterwards.

| improve this answer | |
0

Following JayDin's comment I confirm the simpliest solution on 16.04 (XFCE) is:

  1. Open Ubuntu Software and search for fwupd
  2. Install only fwupd (no need for fw-uefi-tools)

This will upgrade the daemon version which is sufficent to complete the job. Run fwupdmgr --version to check:

# fwupdmgr --version client version: 0.8.3 daemon version: 1.2.10

| improve this answer | |
  • That way you have both apt version and snap version of the software installed. Use fwupd.fwupdmgr for the snap version. – jarno Aug 19 '19 at 2:57
0

Try sudo fwupdmgr -v update with mouse off and it's done.

This worked on 5.3.0-19-generic #20-Ubuntu.

| improve this answer | |
0

For me these commands worked

   sudo apt remove fwupd

   sudo snap install fwupd --classic

   sudo fwupdmgr refresh

   fwupdmgr update

   sudo fwupdmgr -v update (mouse on)
| improve this answer | |
  • This is a duplicate of another answer – damadam Dec 2 '19 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.