9

I am trying to install Ubuntu Desktop 18.04 LTS along side Windows 10, but it's not detecting my Samsung EVO 960 PCIe NVME SSD(500 GB). The same is visible and useable from Windows 10 Professional. What could be the issue?

Rather than directly installing. first i went into the "try without install mode" and opened gparted...gparted showed SATA SSD, other hard drives, USB drive but not the Samsung PCIe NVME SSD.

Anything else i need to have in my bootable ISO image to detect the PCIe NVME SSD? My BIOS mode is UEFI(that's the one via which Windows has been installed), is that the issue as mentioned here? Mine is Dell XPS 8930 Desktop - Intel Core i7-8700(6 Cores Processor with 64 GB RAM, Windows is installed on SATA SSD and I am trying to install ubuntu Linux 18.04 LTS on PCIe NVME SSD).

Edit 1 Rather than trying Ubuntu, I went ahead with the install but end up with some bugs...Ubuntu was not able to detect Windows 10 installation on my computer...enter image description here...Seems that 18.04 LTS is somewhat too early to try it out.

Edit 2 Googled on Internet for Dell XPS desktop/laptop specific issues and found these links: link1 link2 link3

Went into BIOS(F2) and changed the SATA setting to from RAID On to AHCI BIOS warned at the time of saving this setting that either I may not be able to boot my Operating System(Windows 10) or I need to re-install it. I went ahead...couple of times...restart at the BIOS level...Operating system never came up...finally BIOS went into the health check and recovery mode...i reverted back the setting to RAID On and at least Windows 10 is able to boot.

Dell's BIOS doesn't seems to be that easy to work with for dual boot Linux or PCIe NVME drive it seems...will try it later during the weekend.

Edit3 Somehow Ubuntu installer was not able to detect Windows 10. Googled it further and then changed the BIOS back to secure boot enabled and UEFI enabled. Now Ubuntu installer was able to detect Windows 10. Installation happened successfully on my shinning Samsung PCIe NVME SSD without any issues.

  • Make sure you boot from the USB in the UEFI mode. – user68186 May 3 '18 at 23:18
  • Try turning off Secure boot. – WinEunuuchs2Unix May 3 '18 at 23:25
  • @WinEunuuchs2Unix. SecureBoot is disabled. A month back - I was trying to install Ubuntu 16.04 LTS and I had the same PCI NVME SSD attached via the adaptor card and installer was able to detect it. The only issue at that time was Intel Optane which came in the way for dual boot. This time I removed Intel Optane and put this PCIe NVME(Samsung) drive in that slot. Why 18.04 LTS is not recognizing or detecting it at /dev/nmveXX at all? – Ashu May 4 '18 at 1:45
  • I think Optane is usually used in tandem with Intel Rapid Storage Technology. Is Rapid Storage turned off (drive decelerated) in Windows? – WinEunuuchs2Unix May 4 '18 at 2:14
  • Yes Optane has been disabled and removed from the system totally. But what exactly is the Rapid storage and how it can be turned off? BIOS or from Windows? – Ashu May 4 '18 at 2:24
12

Well after a lot of google search I came across this post. The issue was at the BIOS level. In case of Dell desktops and laptops - one has to set the SATA mode to AHCI rather than the default Raid On. If you don't follow the above post - your machine won't boot Windows 10 as the AHCI driver is by default not installed. That's why one need to go into the safemode first then make the changes in BIOS and then disable the safemode. Being in the safemode - it installs the AHCI drivers via which O/S can talk to the drives. After this I booted via the live USB and i can see the Samsung PCIe NVME SSD being visible from the gparted.

| improve this answer | |
  • But if you do that, won't that disable Optane? And if you switch it back to RAID afterwards to re-enable Optane, will you still be able to dual-boot? I also have a similar system, except my 960's 1TB. I've disabled secure boot and CSM. This is why I was hesitant about getting back into a dual-boot desktop. Ever since UEFI, trying to do a dual-boot is a nightmare. – Larry Wilson May 23 '18 at 14:24
  • 2
    I have taken out my Intel Optane forever. It's 16GB Cache and works only for Windows. It has created enough issues for me and never let me had a dual boot Windows and Linux. I have used the same PCI slot and using it for my PCIe NVME Samsung SSD. So i don't have to re-enable Raid On. – Ashu May 23 '18 at 17:26
  • This is not an answer as I have not enough reputation to comment hence posting this as answer. @Ashu can you please layout the steps for me to follow to install ubuntu 18.04 along side windows. I have dell g3 15 3000 with 16gb optane + 1TB HDD – manish bhanga Nov 9 '19 at 8:51
1

I was having this issue with an Acer TC-885-UA92. Brand new, since it came with a windows 10 license, I decided to dual-boot with Linux. First time using a computer with a PCIe NVME SSD. I shrank the partition from Windows 10. The installer wouldn't recognize the empty space, and some installers kept ONLY recognizing the USB drive and wanting to install to it.

From this and other posts I found I tried:

  • Tried looking in Gparted, but again only recognized the thumb drive.
  • Tried finding through terminal in /dev/ /media /mnt and lsblk wouldnt bring it up either.
  • Multiple thumb drives and flashing from different pcs
  • Different Distros, none of the installers would recgonize the empty space
    • Linux Mint 19.2, 19.1, even 19.3(beta)
    • KDE Neon
    • Ubuntu 18.04, 19.10, Kubuntu 19.10
  • Setting RAID to AHCI
  • Disabling Secure Boot
  • Disabling "Fast Boot" from within Windows 10

What finally worked for me though was AFTER booting to a usb drive, but BEFORE launching into the live session, going into the boot parameters, and adding nvme_load=YES The installation went without a problem after this.

| improve this answer | |
0

You need to make Windows work without Optane since it is not supported (and not that useful anyway...) by Linux. Follow this procedure:

1) Start in Windows and run cmd as admin

2) Put Windows into safeboot mode with:

bcdedit /set {current} safeboot minimal

3) Restart and enter immedialy into the BIOS during boot and change disk interface from Optane to AHCI mode, then save and exit

4) In Windows (it will start in safe mode) run cmd again as admin

5) Make Windows boot again in normal mode with:

bcdedit /deletevalue {current} safeboot

6) Restart your PC and check that now Windows in running normally with the AHCI driver

7) Reboot and proceed with the Linux installation as usual...

| improve this answer | |
0

Some additions to lostsaint's answer:

I followed everything there and got a mostly clean install of Ubuntu 19.10. I needed the "safe graphics" option to get started. See below for important caveat about the instructions. In retrospect it's not clear to me that the RAID/ACPI thing is an issue. The Linux installer couldn't see the NVME root disk in ACPI mode without nvme_load. For those unfamiliar with NVME the disk shows up as /dev/nvme*, nvme0n1p* in my case.

I had messed up graphics on system reboot. I successfully booted with nomodeset and replaced the Nvidia drivers. The answer from Orhan G. Hafif here: Nvidia GTX 1650 not detected in Ubuntu 18.04.3 was most helpful and applied to my 19.10 system.

Now for the major caveat. Before you set things up to boot Windows into safe mode, make sure you have an administrator login that does not need the Internet. Pull your network cable, turn off wireless, and make absolutely sure you can still log in. Otherwise, when Windows is in minimal safe mode it will not let you log in because it has no way of verifying your credentials. Period. Not even a cmd prompt in safe mode. I didn't do this, and wound up removing my login and starting over. It may have been possible to break in, but I couldn't see how and since I hadn't really customized my Windows environment this was the path of least resistance.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.