8

After upgrading non-essential PCs to 18.04, while keeping my primary PC on 17.10, I'm running into a minor problem with networking and Nautilus in 18.04.

When I select Other Locations in the Nautilus sidebar, I expect to see the other machines on my network plus my Windows network. They are all there on machines running 17.10, but don't appear in 18.04. Also in 18.04 although there is an icon for the Windows network, clicking on it doesn't bring up the existing Workgroups as it does in 17.10.

My /etc/samba/smb.conf files are identical on all machines. I can access the shares from the 18.04 machines by running:

nautilus smb://<ip address>

in a terminal, which is why I suspect it has something to do with Nautilus rather than Samba. The Nautilus version on the 17.10 machines is 3.26.0, on the 18.04 machines is 3.26.3.

9

There's two different issues in your description.

The "Windows Network" problem is due to samba changing a client protocol level: https://ubuntuforums.org/showthread.php?t=2384959

To restore it to how it used to work: Install smbclient:

sudo apt install smbclient

Then edit /etc/samba/smb.conf and add a line under the workgroup = WORKGROUP line:

client max protocol = NT1

Save the file and reboot ... yes ... reboot.

Please read the forum post about why Samba changed this to see if it affects you.

The other issue about not finding 17.10 samba servers seems odd because starting with that release they should be "published" automatically regardless of protocol level. I would see if the following service is running on all your machines:

sudo service avahi-daemon status

If it's not running restart it:

sudo service avahi-demon start

Changing the client max to NT1 should also fix the Ubuntu 17.10 discovery but the avahi method really should be working by default.

  • The first part of the answer solved my problem, the avahi-daemon was already running. – Richard Quint May 3 '18 at 20:54
  • client max protocol = SMB2 also worked for me. SMB3 not. – s.k Dec 13 '18 at 13:19
  • client max protocol = NT1 - thank you, thank you! Been trawling for the answer to this for days. Although now I have two local shares showing for this machine, both smb://xubuntu.local and smb://xubuntu. I can live with this though. Going to now see if the same works on my Debian box. – Fiddy Bux Jan 7 at 21:56
0

I had to disable ufw firewall to make windows network browsing work. Have not figured out what rules to make it work with firewall on.

Status: active

To                         Action      From
--                         ------      ----
137,138/udp                ALLOW       Anywhere                  
139,445/tcp                ALLOW       Anywhere                  
Apache Full                ALLOW       Anywhere                  
Samba                      ALLOW       Anywhere                  
Samba (v6)                 ALLOW       Anywhere (v6)             

22/tcp                     ALLOW OUT   Anywhere                  

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.