After upgrading non-essential PCs to 18.04, while keeping my primary PC on 17.10, I'm running into a minor problem with networking and Nautilus in 18.04.

When I select Other Locations in the Nautilus sidebar, I expect to see the other machines on my network plus my Windows network. They are all there on machines running 17.10, but don't appear in 18.04. Also in 18.04 although there is an icon for the Windows network, clicking on it doesn't bring up the existing Workgroups as it does in 17.10.

My /etc/samba/smb.conf files are identical on all machines. I can access the shares from the 18.04 machines by running:

nautilus smb://<ip address>

in a terminal, which is why I suspect it has something to do with Nautilus rather than Samba. The Nautilus version on the 17.10 machines is 3.26.0, on the 18.04 machines is 3.26.3.


4 Answers 4


There's two different issues in your description.

The "Windows Network" problem is due to samba changing a client protocol level. https://ubuntuforums.org/showthread.php?t=2384959

To restore it to how it used to work:

Install smbclient:

sudo apt install smbclient

Then edit /etc/samba/smb.conf and add a line under the workgroup = WORKGROUP line:

client max protocol = NT1

Save the file and reboot ... yes ... reboot.

Please read the forum post about why Samba changed this to see if it affects you.

The other issue about not finding 17.10 samba servers seems odd because starting with that release they should be "published" automatically regardless of protocol level. I would see if the following service is running on all your machines:

sudo service avahi-daemon status

If it's not running restart it:

sudo service avahi-daemon start

Changing the client max to NT1 should also fix the Ubuntu 17.10 discovery but the avahi method really should be working by default.

  • The first part of the answer solved my problem, the avahi-daemon was already running. May 3, 2018 at 20:54
  • client max protocol = SMB2 also worked for me. SMB3 not.
    – s.k
    Dec 13, 2018 at 13:19
  • client max protocol = NT1 - thank you, thank you! Been trawling for the answer to this for days. Although now I have two local shares showing for this machine, both smb://xubuntu.local and smb://xubuntu. I can live with this though. Going to now see if the same works on my Debian box.
    – Fiddy Bux
    Jan 7, 2019 at 21:56
  • 1
    I my case I also had to modify server min protocol see askubuntu.com/a/1235391/46262
    – lanoxx
    May 4, 2020 at 21:11

I had to disable ufw firewall to make windows network browsing work. Have not figured out what rules to make it work with firewall on.

Status: active

To                         Action      From
--                         ------      ----
137,138/udp                ALLOW       Anywhere                  
139,445/tcp                ALLOW       Anywhere                  
Apache Full                ALLOW       Anywhere                  
Samba                      ALLOW       Anywhere                  
Samba (v6)                 ALLOW       Anywhere (v6)             

22/tcp                     ALLOW OUT   Anywhere                  

Disabling firewall indeed solves the problem.

the other solution is to let pass incoming traffic from the intranet (for example x.x.x.1/24) on udp with source port set to 137 , and also let pass incoming traffic from the intranet on udp with destination port set to 137. The other ports of netbios need not to be opened.

  • Welcome to AskUbuntu! could you possibly add a bit more detail to your answer? Is this change made on the computer or on the router? HOW does one "let pass incoming traffic from the intranet" ? thanks! Jul 29, 2019 at 18:10
  • It is just working because i have a working winsserver on the nas.
    – user979675
    Jul 30, 2019 at 20:49
  • The change is made on the computer by changing firewall rules by gufw. I have to say it was working, but now it does not work any more because my nas is down, so I have no more winsserver.
    – user979675
    Jul 30, 2019 at 20:53

I encountered this issue on a Ubuntu 18.04 system that had installed SAMAB, via sudo apt install samba, with the application "Gufw Firewall" activated.


To overcome this issue, after opening the gufw application, i.e.


I clicked on the Rules button, followed by the + button, and made these settings:

Added rules

After pressing the Add button, the firewall rules that allowed SAMBA share were created and reflected in the Rules table of gufw. gufw with SAMBA rules

Thereafter, in nautilus --> Other Location --> Networks, my machine name would appear there and the machine's shared folder(s) that was created with nautilus-->Local Network Share became detectable by other systems in the same network.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .