1

thanks in advance for any help.

 

My Server:

I just installed a Ubuntu Server 17.04 with basic software and LAMP. (I first tried 18, but because of this bug (https://bugs.launchpad.net/ubuntu/+source/curtin/+bug/1767569) I cannot install it from an usb device.

Goal is to have a local webserver in my current intranet. Apache, PHP and MySQL are all running fine.

I already configured my DNS to point to the webserver and I get the apache default site. When opening my phpinfo I get PHP Version 7.0.15-1ubuntu4, so php7 is running fine.

Haven't tried the ftp yet, but that could be done later.

 

Problem:

All I need now is to get phpmadmin running, because right now I get an error when opening /phpmyadmin So I checked the server and it seems like phpmyadmin isn't installed together with LAMP (no phpmyadmin folder in /usr/share/)

 

What I have tried so far:

  1. I've added deb http://us.archive.ubuntu.com/ubuntu/ zesty universe multiverse and deb http://us.archive.ubuntu.com/ubuntu/ zesty-updates universe multiverse to the repo list
  2. I've added the phpmyadmin repository sudo add-apt-repository ppa:nijel/phpmyadmin
  3. I've apt-get update and apt-get upgrade multiple times
  4. Used apt-get install -f
  5. Many more things I cannot remember right now, but have been reverted afterwards.

 

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
phpmyadmin : Depends: php but it is not installable
              Depends: php-mbstring but it is not installable
              Depends: php-xml but it is not installable
              Depends: libjs-sphinxdoc (>= 1.0) but it is not installable
              Depends: dbconfig-mysql but it is not installable or
                       dbconfig-no-thanks but it is not installable or
                       dbconfig-common (< 2.0.0) but it is not installable
              Depends: php-php-gettext but it is not installable or
                       php-gettext (<= 1:7.0) but it is not installable
              Depends: php-phpseclib (>= 2.0) but it is not installable
              Recommends: php-curl but it is not installable
              Recommends: php-gd but it is not installable
              Recommends: php-bz2 but it is not installable
              Recommends: php-zip but it is not installable
              Recommends: php-tcpdf but it is not installable
E: Unable to correct problems, you have held broken packages.

 

Now when I issue the command apt-get install phpmyadmin php php-mbstring php-xml libjs-sphinxdoc dbconfig-mysql php-php-gettext php-phpseclib php-curl php-gd php-bz2 php-zip php-tcpdf I get following errors:

 

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-mbstring is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-xml is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libjs-sphinxdoc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package dbconfig-mysql is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-php-gettext is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-phpseclib is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-bz2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-zip is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php-tcpdf is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php' has no installation candidate
E: Package 'php-mbstring' has no installation candidate
E: Package 'php-xml' has no installation candidate
E: Package 'libjs-sphinxdoc' has no installation candidate
E: Package 'dbconfig-mysql' has no installation candidate
E: Package 'php-php-gettext' has no installation candidate
E: Package 'php-phpseclib' has no installation candidate
E: Package 'php-curl' has no installation candidate
E: Package 'php-gd' has no installation candidate
E: Package 'php-bz2' has no installation candidate
E: Package 'php-zip' has no installation candidate
E: Package 'php-tcpdf' has no installation candidate

 

Right now I don't know what else I can to, but asking here. I've seen that a lot of users already had issues with getting phpmyadmin work on a Linux with LAMP, but I seems that all those issues got resolved with solutions I have already tried. I would really appreciate any help here. (If you ask: Apart from the changes in the sources.list I've mentioned above I didn't add any other repos.)

  • It seems like the issue could be the server version. I've read somewhere that 17.04 is unsupported. Right now I am about to install 16.04 LTS. Maybe this helps – FrischVerwegen May 3 '18 at 15:28
1

Alright,

solution was just like I posted in my comment above. Version 17.04 is end of lifetime and therefore I wasn't able to find any software. I reinstalled 16.04 LTS and everything works perfectly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.