1

Alt+F1, Alt+Tab etc does not work anymore. When I try to access Global Shortcuts it says "Failed to contact KDE global shortcuts daemon". Then I launched kglobalaccel manually. It starts silently without any specific error message:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

kbuildsycoca4 running...
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

Global shortcuts app becomes accessible, but keyboard shortcuts still does not work. Similar questions there are about Unity and Compiz, but what about KDE?

Related info: Ctrl+C and Ctrl+V still work though. Ctrl+Alt+Fn works strange: F1 is current session, F7 opens new session in terminal, others show blank screen.

Reinstalling libkf5globalaccel-* didn't help.

Also, I tried to delete kglobalshortcutsrc settings file in $HOME/.config/ and default one didn't appear neither after reboot, nor reinstallation of libkf5globalaccel.

kglobalaccel5 also starts, says nothing.

journalctl -f | grep --line-buffered kde Says only about baloo not working (and I'd prefer not to care about it):

тра 03 17:35:50 hcl-GL553VD dbus-daemon[2047]: [session uid=1000 pid=2047] Activated service 'org.kde.runners.baloo' failed: Process org.kde.runners.baloo exited with status 1
тра 03 17:35:50 hcl-GL553VD dbus-daemon[2047]: [session uid=1000 pid=2047] Activating service name='org.kde.runners.baloo' requested by ':1.104' (uid=1000 pid=3553 comm="/usr/bin/plasmashell " label="unconfined")                                                                                                        
тра 03 17:35:50 hcl-GL553VD org.kde.runners.baloo[2047]: QSocketNotifier: Can only be used with threads started with QThread
тра 03 17:35:50 hcl-GL553VD org.kde.runners.baloo[2047]: QSocketNotifier: Can only be used with threads started with QThread
тра 03 17:35:50 hcl-GL553VD org.kde.runners.baloo[2047]: QSocketNotifier: Can only be used with threads started with QThread
тра 03 17:35:50 hcl-GL553VD org.kde.runners.baloo[2047]: qt.qpa.screen: QXcbConnection: Could not connect to display :20
тра 03 17:35:50 hcl-GL553VD org.kde.runners.baloo[2047]: Could not connect to any X display.
тра 03 17:35:50 hcl-GL553VD dbus-daemon[2047]: [session uid=1000 pid=2047] Activated service 'org.kde.runners.baloo' failed: Process org.kde.runners.baloo exited with status 1

UPD: Ok, after reinstalliing libkf5globalaccelprivate5 and relaunching kglobalaccel5, I can set Alt+F1 as shortcut for Application launcher in Global Shortcuts and it starts working. Screenshot is not working (Spectacle not launched though installed). But all the settings are lost on reboot! I need to create shortcuts again, and kglobalaccel5 also does not start automatically.


Upd2: I found that there are some very strange settings in the default file: https://github.com/dnephin/dotfiles/blob/master/.kde/share/config/kglobalshortcutsrc

For example, Alt+F1 is for "switch to desktop 1" and Alt+F4 is for "Switch to desktop 4".

  • 1
    Could you please try to revise the question so that it only is a question and then post your solution separately as an answer? – DK Bose May 7 '18 at 12:05
1

Ok, this time settings seem to be saved after reboot. So what I did it somebody will face the same issue:

  • reinstalled libkf5globalaccel-* and libkf5globalaccelprivate5, checked that kglobalaccel5 starts from console. Do not use kglobalaccel command.
  • replaced $HOME/.config/kglobalshortcutsrc with the default one from github
  • added kglobalaccel5 to autostart, rebooted.
  • fixed wierd shortcuts for Alt+F1, etc. via Global Shortcuts (Alt+Tab also needed reassigning).

Screenshots still does not work though. Custom Shortcuts -> Take full scree shot works. It does not launch Spectacle, shows popup notifying that screenshot was saved. Spectacle crashes when launched by hotkey somewhy (but works ok if launched manually).

UPD: Screenshots configured through Custom Shortcuts stopped working again, looks like a separate bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.