5

I have been trying to get Ubuntu work on my laptop (dual boot alongside Windows 10) for quite a while now. It all started with me installing Ubuntu 16.04. It worked just fine, but I wasn't able to adjust my keyboard backlight's brightness. It glowed to its full extent, draining my battery in an hour and a half. All the solutions offered on the internet did not work, including updating to a new kernel version, leaving me frustrated and disappointed. I waited until 17.04, but couldn't install due to it crashing when Try Ubuntu or Install Ubuntu is selected (Errors that showed up are listed at the end). Waited for 17.10, same problem, no hope. Now it's 18.04 and I'm still facing installation issues with Ubuntu.

Here's what happened.

I burned the image of Ubuntu 18.04 to my USB drive using Rufus on Windows. Shut my PC down, plugged in the USB, changed UEFI Boot order, and I got the "Try Ubuntu, Install Ubuntu ... " screen. When I select either of those (Try or Install) the splash screen for Ubuntu appears, I see the red dots popping in and out and the system crashes. One fix I found was to change quiet splash to nomodeset in the GRUB options. Then Try Ubuntu worked, and I installed Ubuntu 18.04.

The problem now was that I wasn't able to change my brightness. I didn't see any brightness adjustment slider on the top, and neither the function key for brightness (Fn+F5, F6) worked. After I restarted upon installation, I tried to switch to nVidia proprietary drivers, hoping it would fix the brightness problem ( In Software & Updates -> Additional Drivers). That made it even worse. The log that is shown during Ubuntu's boot crashes and my laptop's fan begins to run at crazy speeds. There was no hard disk access when that happens (the hard-disk access light stops glowing). I had to hard press power button to force shutdown. I tried Bumblebee, same problem. I tried uninstalling nVidia drivers on recovery, but it still didn't fix my problem.

enter image description here

One thing that quite often popped up while booting Ubuntu (17.10, 18.04) was these two errors:

  1. TSC_DEADLINE disabled due to errata. Upgrade microcode firmware to 0x52.
  2. ACPI Error : AE_ALREADY_EXISTS

The above situation (Ubuntu crashing after Nvidia driver install) is rectified when I set acpi=off in GRUB. But this renders my touchpad unable to use, and I could not shut down my system without having to press the power button. The brightness adjustment slider wasn't there either.

My Laptop's Configuration:

  1. CPU: Intel i5 7300HQ
  2. RAM: 8 GB
  3. GPU: nVidia GeForce GTX 1050 (2GB GDDR5 VRAM)

I was running the latest BIOS provided by ASUS the whole time.

  • Same problem. I wasn't even able to install kubuntu 18.04. The try mode hangs forever, the install mode does not permit me to install ubuntu on the first disk (128GB) where ubuntu 16.04 is installed. I just asked a question here: askubuntu.com/questions/1032255/… – Mario Stefanutti May 5 '18 at 6:50
  • @Mario Yeah. It's frustrating. I also tried Linux Mint 18.3 just a couple of hours ago, same problem! It might be a broken ACPI packed up with our laptops! – Nandhakishore May 5 '18 at 14:47
2

I had the same problem with all kernels after 4.13. Try to use acpi_osi=! as kernel parameter. That's What I did and worked. I also had the same problem with ASUS laptop FX503VD and tested this on Manjaro and Kubuntu.

  • 1
    How can I pass a parameter to the kernel? – Bruno Quaresma May 8 '18 at 4:51
  • 1
    when you are on the grub screen at boot press 'E' and just add 'acpi_osi=!' (without the quotes) right after quiet splash. – perbasilopou May 8 '18 at 10:37
  • If it boots and works properly follow these instructions here – perbasilopou May 8 '18 at 10:39
  • @perbasilopou Thanks. I'll try this and notify you as soon as possible. – Nandhakishore May 9 '18 at 7:29
  • This solution does not fully fix my problem. I can adjust brightness but cannot use touchpad with acpi_osi=! enabled. With acpi_osi=Linux , it's exactly the opposite. I can boot into Ubuntu though. Kudos for that. – Nandhakishore May 10 '18 at 17:16
1

The acpi_osi=! solution did not work. If you came across this question hoping for some help, then go to http://pclub.in/2017/01/06/Linux-on-Asus-ROG.html and follow the instructions. It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.