6

I tried disabling nouveau drivers in Ubuntu 18.04 by putting these lines in /etc/modprobe.d/blacklist.conf:

#Blacklist nouveau drivers
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

and updating initramfs.

On reboot the gdm won't start, blocked in the last line:

GDM error:

enter image description here

Trying to enter any tty, I get the same error (I had to undo changes from rescue mode).

The same procedure was working on 17.10 (with xorg).

My PC is an Asus ux430uq with clean install of ubuntu 18.04 (4.15.0-20 kernel).

I am afraid of uninstalling xserver-xorg-video-nouveau drivers since I don't know how to reinstall them if something go wrong (I can't get internet working in rescue mode).


EDIT:

Uninstalling the above package lead to the same error. Trying to boot ubuntu with the kernel flag nouveau.modeset=0 gives the same error too.

8

I found the solution. I'll write it here for who may have the same problem.

My gdm3 session was running in wayland. To check it:

 $ loginctl
 SESSION     UID  USER     SEAT     TTY             
       2    1000  velix    seat0    tty2            
      c2    1000  velix                                             
      c1     120  gdm      seat0    tty1

The command loginctl show-session <session-n> -p Type show the session type:

$ loginctl show-session c1 -p Type
Type=Wayland

To change it, edit the file /etc/gdm3/custom.conf and uncomment the line WaylandEnable=false.

After rebooting:

$ loginctl show-session c1 -p Type
Type=x11

Now blacklisting nouveau drivers in /etc/modprobe.d/blacklist.conf (as in the question) works and doesn't give the above error.

The key point is to run xorg instead of wayland

(That's why it was working in my 17.10 ubuntu, forced to run xorg)

  • +1 Thanks for sharing. Don't forget to accept your answer by clicking check mark next to it in a day or so when it lets you. – WinEunuuchs2Unix May 4 '18 at 23:13
  • 1
    Gives black screen on a MacBook, answer no longer works? – Gabor May 9 '18 at 2:10
  • My answer is 5 days old. This method is still working on my notebook. – velix May 9 '18 at 16:24
  • On a MacBook, where I have the error same as in your screenshot, I only get a black screen. Loginctl also errors out with Failed to create bus connection – Gabor May 9 '18 at 20:24
  • I think it's a different problem. Open a new question and put more info in that. – velix May 10 '18 at 9:58
2

https://bugs.launchpad.net/nvidia-drivers-ubuntu/+bug/1784598

try:

sudo systemctl disable nvidia-fallback.service
1

Got exactly same problem, my configuration is x11 (returned by loginctl command). The only way working for me at the moment is to rename the nouveau file module.

# pwd
/lib/modules/4.15.0-20-generic/kernel/drivers/gpu/drm/nouveau
# mv nouveau.ko nouveau.ko-old
# reboot

dirty solution but working, hope it will help. Of course, all was fine in 17.10.

0

Don't forget to disable Secure Boot in BIOS especially when you want nvidia (and not nouveau) driver working. Otherwise it will quite always fall back back to nouveau no matter what you do.

Also note that "Secure Boot" option can be hidden in BIOS under various options on various places and often that option is not saying anything about "Secure Boot" but sometimes it's called "Other OS" similar. Every BIOS can be quite unique here. It took me several days of trying various approaches until I went back to BIOS as last resort. It cannot be emphasized enough especially when you are upgrading 18.04 from older version.

0

Add modprobe.blacklist=nouveau to kernel cmdline. This worked on my laptop.

  • It's the same of adding "blacklist nouveau" in /etc/modprobe.d/blacklist.conf as I stated in my question. In my case it won't solve the problem, probably yours is a different situation (e.g. you're already on xorg). – velix Feb 24 at 15:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.