1

I installed xubuntu 18.04 from a usb onto my Acer Aspire ES1-572-37EP which has Windows 10. It also has Anarchy Linux installed.

The problem is that when I reboot, the machine just boots the Windows and doesn’t offer a menu to choose either of the other OSs.

The BIOS is in UEFI boot mode and secure boot is disabled. In the Windows control panel, I have turned off the fast startup option. When I did the installation, I chose to boot from the Windows boot manager and in the edit partitions screen I selected sda1 as the boot/efi partition without formatting (actually, the formatting option was grayed out). sda6 as swap and sda7 as the new xubuntu root (/) partition. (Anarchy is on sda5 and sda8 is used for file storage.

What do I need to do to get an OS selection menu to appear when I boot up?

Thanks and good night.

1

After reading and trying many things, I found an answer in forum question #485261.

This is what worked for me.

I recommend trying the following command in a Windows Administrator Command Prompt window:

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

(If you've disabled Secure Boot, you can replace shimx64.efi with grubx64.efi, although either should work with Secure Boot disabled.)

Since I have secure boot disabled, I did: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

  • I do this and get an error "The set command specified is not valid. The parameter is incorrect". Also, when I do "dir \" I see not directory called EFI. – Erel Segal-Halevi Oct 16 '18 at 5:55
0

In Bios you have the option: Select an UEFI file as trusted for executing. Open this, then you need to find a directory ubuntu, and you need to select the grubx64.efi file as trusted. And also give a description for the efi file like "grubx64".

The next step is moving the EFI File "grubx64" as first Boot Manager, and you should be able to have the options for both OS. You need also to disable FAST STARTUP in windows 10, before trying these steps.

  • Thanks, but I already found a different method that worked, which I just posted. But I really appreciated your answer and I'll keep it in my personal "help" files to try if I ever have to re-install. – Randall Paul Allen May 3 '18 at 11:12

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.