I have a HP TouchSmart tm2150es with hybrid graphics (ATI Mobility Radeon HD 5450 + Integrated Intel HD). It comes shipped with W7 Home Premium 64 bits. It has an Insyde BIOS.

I have certain experience time using Ubuntu Linux and I have installed a multiboot system.

The fact is that graphics have failed since pendrive install. With Natty/Ocelot 64 bit installation pendrive, screen turns black or system hangs, unless I modify boot parameters, adding acpi=off. Thanks to that I could install Ubuntu. Then I start with my brand new Ubuntu in the HDD, but with the same problem.

I have read and tried some stuff:


This suggests to download and install the last proprietary drivers directly from AMD in Fedora's format, convert it to Debian's and install, but takes no better results, because I obtain a graphics card dump and I only can access with Ctrl + Alt + F1.

I have tried even updating the BIOS to the last HP's available version. UPDATE: Insyde BIOS don't give any possibility of changing the operative GPU.

I know that the problem is the hybrid architecture, but don't know how to fix the problem.

Could someone help me trying anything else?

  • Please try using only one graphic gart at a time. Set options in BIOS to use only one card. For example try setting ATI card and then install drivers for it. Does it work fine? Regardless to result try the same for Your intel card. What are the results? – Misery Feb 10 '12 at 18:34
  • Thanks Misery, but the Insyde BIOS don't give any chance for that. – Hefaesto Feb 10 '12 at 19:22
  • Oh, really? Maybe You need to enable some advanced options. Have You checked Your mainboards manual? If that really is so You cant disable one of the cards, that's going to be hard puzzle to solve Your problem in my opinion. – Misery Feb 10 '12 at 19:27

if your laptop is a mux one (as mine),the only driver working is fglrx 11.8. I succeed to make it works including switching from intel to ati chipset on ubuntu 10.04. newer distribution as ubuntu 11.04 and 11.10 aren't supported by this driver version.

If you only need intel, the i915 included in all distribution is sufficient (and use vga_switcheroo to deactivate ati chipset to save battery time...). It's the only solution as now for newer distributions with my hardware.

My Bios is as yours : no switching option (if you have one, you can disable ati card in bios and use newer fglrx version, it's not my case).

If you have a mux one and take a look at Xlog, you should see "fglrx is not supported on A+I Mux platform, please uninstall" with newer ATI drivers (it possibly your blackscreen problem).

Hope this help.

  • Thanks user41128. You put me in the right way. Now I'm making tests, but I'm capable of activating one or the other with the system running (must switch gfm off and on before changes) with the vgaswitcheroo flags. When I came a couple of steps forward I will write some feed back here. – Hefaesto Feb 14 '12 at 0:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.