1

I constantly have error F7701-1003 trying to play Netflix on Ubuntu 18.04 using FireFox 59.0.2.

I already googled the problem and tried following:

-enabled DRM in the settings, let FF download and install DRM software (widevine I suppose), restarted FF, even rebooting ubuntu completely

-not using VPN

-disabled all extensions

-disabled tracking protection

-not using private mode

-switching user agent data to mac/win and browser to chrome

Same machine on same network plays Netflix flawlessly on Windows 10 using FF as well.

3
  • What specifically are you asking?
    – SDsolar
    May 2, 2018 at 21:00
  • I tested your problem with my setup. (Host: Macos High Sierra , Guest : Ubuntu 18.04 Firefox 59.0.2 DRM enabled. No other settings configured and it works normally as far as I can see)
    – Ege Sucu
    May 3, 2018 at 17:28
  • I've faced the same issue. This problem is caused by the DRM module. In my case the root of problem was the disabled seccomp option in the custom built vanilla kernel. Also the uncomplete updated (especially glibc) can be cause the same issue. I hope it can help someone. May 18, 2020 at 19:17

1 Answer 1

2

Go into Preferences » Privacy & Security » History. If you have told Firefox to "Never remember history" then you will get the F7701-1003 error. Change it to "Use custom settings for history" and then make sure all four of the check-boxes that appear underneath it are unchecked. Netflix should now work.

Note: You probably don't need to have all four of those checkboxes unchecked. I suspect only the first two are essential. I haven't, however, bothered to test the theory. :)

1
  • Solution worked for me - Ubuntu 20.04, Firefox 79.0
    – Matt
    Aug 24, 2020 at 18:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.