I installed eclipse via Ubuntu Software. When I start it, it take some seconds and then comes an error window showing the path of the error.

The following is the .log file:

!SESSION Wed May 02 12:53:28 BRT 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-05-02 12:53:28.587
!MESSAGE Exception launching the Eclipse Platform:
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
    at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

What is the problem and how can I fix it?

  • By the way Netbeans also doesn't start. I don't know if it is related.
    – Roberto
    May 2 '18 at 16:11
  • I solved the Netbeans issue installing from Oracle installer.
    – Roberto
    May 2 '18 at 17:25

It's another one of those fun new bugs caused by the new Java (it broke Arduino, too, in multiple annoying ways). The bug report is here: https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1754886.

Essentially, there's some sort of recursive dependency with multiple versions of a library required by different parts of the program, and they won't fix the bug since "This is only one of the more obvious bugs affecting Eclipse" and they don't have enough people on it.

For some reason, they also have not packaged the newer Eclipse (we are an entire major version later at this point) except in the Snap Store (it shows up if you search Eclipse in the GUI software center), which is where the mentioned "other version of Eclipse" comes from.

Your options are to download Eclipse from their site or to install the Snap if you want to keep using the program (and Netbeans broke too, for the same Java reasons). I would personally install the version from their site, but snaps hypothetically are safer and easier to set up.

  • 2
    I tried the snap and got bitten later when trying to use WindowBuilder. It looks all fine at first sight until you find an issue which is not uncommon for complex software like IDEs, then you find that the snap/flatpak is not up to date or the issue exists in the edge channel too (this is the second IDE I where I have an issue with snap/flatpak). I think there is at least a lot more effort required than relying on that the community will convert most software flawlessly from traditional to new formats. Particularly for complex software that may look like just a text editor but isn't. :)
    – LiveWireBT
    Nov 7 '18 at 9:33

I struggled with this as well. Decided to do sudo apt-get purge eclipse... and used snappy packaging system

sudo apt install default-jre
sudo snap install --classic eclipse

.... icon will appear and you are ready to go


Problem solved. In my Ubuntu Software there were 2 versions of Eclipse, one in Portuguese and one in English.

I noticed the logo changed, installed the one with the new logo - in English - and it is working.


try this one

sudo update-alternatives --config java

This will list all the Java versions installed in your system.

Now , try select the java version 8.
And then try to open eclipse.

  • 1
    Nope: "There is only one alternative in link group java (providing /usr/bin/java): /usr/lib/jvm/java-11-openjdk-amd64/bin/java Nothing to configure." Oct 25 '19 at 14:55
  • This is the solution. You need to install java 8 or openjdk 8
    – xvan
    Apr 23 at 4:38

I've just encountered this problem (posted a few days ago at Unable to launch Eclipse on Ubuntu 18.04 - I didn't find this post at the time. @N0rbert: thank you for pointing me to it).

After I posted, I went to the Eclipse web site and found that there is an installer: Eclipse Installer 2019-09 R. I downloaded it and ran it and it seems to have worked: I can start and run Eclipse without problems and do a bit of editing. I can't yet confirm that I won't run into problems when I get deeper into it. I will post again once I have anything new to report.


I too had this problem, however the official installer also failed me (and many others apparently, see https://www.eclipse.org/forums/index.php/t/1075546/), so I ended up downloading the .tar.gz package of the 'installed' IDE, unpacking it in a convenient location and dropping a symlink to the executable into my ~/bin.

Also I've come across people saying the snappy version seemed to be working initially, but broke later in unexpected ways, as it is outdated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.