0

I checked the Synaptics touchpad configuration using terminal, but what I saw is that palm detection was set to 0 like in the picture below.

enter image description here

From my experience, 0 means 'FALSE'. This means NO PALM DETECTION. I would like to set my Synaptics touchpad to recognize my palm.

How can I do that? Could you all please help?

1

My solution might not work for you, but I fixed this issue by switching to Wayland.

I use the Lenovo ThinkPad X1 Yoga 3rd Gen, and the palm detection features when using X.org didn't seem to do anything. I knew that the hardware was capable of doing true Apple trackpad style palm detection, because, on Windows, I could rub my palm vigorously across the touchpad and the mouse pointer wouldn't budge.

To switch to Wayland, log out of your user account, and there should be an option on the login page that shows a dropdown with "Wayland" as an option. If not, see this answer for more details.

Voila! I can now smear my whole palm on the touchpad again and not worry about accidental taps and mouse movement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.