3

I recently installed Ubuntu 18.04 on my laptop. Then I installed Steam via the website yesterday, and it worked. When I tried to launch Steam today it simply crashed as the auto-update began. I used sudo apt-get purge steam when uninstalling and have tried to re-install both with the download from the website and with sudo apt-get install steam. The problem persists however.

This is the output I get when trying to run Steam from the terminal:

~$ steam
cp: cannot stat '/usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz': No such file or directory
Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
Installing breakpad exception handler for appid(steam)/version(1522709999)
Gtk-Message: 16:31:00.768: Failed to load module "atk-bridge"

...

Gtk-Message: 16:31:00.786: Failed to load module "canberra-gtk-module"
dbus[8768]: arguments to dbus_message_new_method_call() were incorrect, assertion "path != NULL" failed in file ../../../dbus/dbus-message.c line 1362.
This is normally a bug in some application using the D-Bus library.

  D-Bus not built with -rdynamic so unable to print a backtrace
crash_20180502163059_1.dmp[8775]: Uploading dump (out-of-process)
/tmp/dumps/crash_20180502163059_1.dmp
/home/magnus/.local/share/Steam/steam.sh: line 927:  8768 Aborted                         (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
crash_20180502163059_1.dmp[8775]: Finished uploading minidump (out-of-process): success = yes
crash_20180502163059_1.dmp[8775]: response: CrashID=bp-a9833971-19cb-45ce-a771-2cb7f2180502
crash_20180502163059_1.dmp[8775]: file ''/tmp/dumps/crash_20180502163059_1.dmp'', upload yes: ''CrashID=bp-a9833971-19cb-45ce-a771-2cb7f2180502''
2
  • Since the file /usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz is missing, it looks like steam-launcher is not installed. Apparently, the steam package has been replaced by steam-launcher.

    Try the following to uninstall the old package and install the new one:

    sudo aptitude purge steam steam:i386
    sudo aptitude install steam-launcher libatk-bridge2.0-0
    

    If steam-launcher is not available, try installing steam-installer instead.

    sudo aptitude install steam-installer libatk-bridge2.0-0
    
  • The package steam-launcher does not install Steam itself. Rather, it is a program that downloads and installs Steam into the user's home directory at $HOME/.local/share/Steam. If Steam is already installed, it is run.

    That Steam was interrupted during an update and is now crashing indicates a problem with the installation directory. You can force a reinstall by moving the installation folder:

    mv "$HOME/.local/share/Steam" "$HOME/.local/share/Steam.bak"
    mkdir "$HOME/.local/share/Steam"
    cp -rl "$HOME/.local/share/Steam.bak/package" "$HOME/.local/share/Steam/package"
    

    Then select the option to "reinstall" when running steam. A few-hundred megabytes of data may need to be downloaded.

    After successfully reinstalling and running Steam, you can look for old games in $HOME/.local/share/Steam.bak and move them to the new installation $HOME/.local/share/Steam. If you have nothing you want to move, $HOME/.local/share/Steam.bak is safe to delete.

  • Last Resort: If none of the above fixes the problem, and you don't mind reinstalling Steam from scratch, you can try deleting all Steam-related files from your home directory:

    \rm -rf $HOME/.steam*
    \rm -rf $HOME/.local/share/Steam*
    
|improve this answer|||||
  • I do not know exactly what those commands did, but now Steam works. Thanks for both your help and your patience. – PrimitiveToast May 6 '18 at 16:00
  • steam-launcher seems not to be part of the default repositories (E: Unable to locate package steam-launcher) From where do you have it? – k0pernikus May 15 '18 at 9:36
  • Steam has its own repositories. To install them, download and install the Steam deb from the Steam website. – xiota Jun 30 '18 at 8:22
-1

run this in your terminal

~/.local/share/Steam/ubuntu12_32/steam

credit to MaiconKeller on the Steam community forum

|improve this answer|||||
  • What does that do? How is that supposed to fix the problem? – xiota Jun 30 '18 at 8:23
  • Not a solution to the original question. – Andor Kiss Feb 5 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.