13

Since I installed Ubuntu 18.04, I can not switch to tty3-7 from the login screen. Until Ubuntu 17.10, this worked perfectly using Ctrl+Alt+F3, F4, .. both from login screen and from user sessions. This is a problem, especially if one is installing a fresh installation and is messing around with /etc/fstab.

I have read that the numbering of tty's changes, e.g. in How do I switch between console mode and GUI in 17.10? but I do now know why changing to terminal does not work from the login screen.

Is there a workaround for that?

Edit When I try to switch, i.e. p.e. hit ctrl+alt+f4, nothing happens (not even a short freeze or so). If I log in and do the same thing, I see the terminal, can login and everything works fine. If I then lock the screen, I can still switch to the terminal.

My graphics card is a RX 480, the mainline drivers are (as far as I know) integrated in Kernel 4.15 and should therefore work. Furthermore, it works with Ubuntu 17.10 with Kernel 4.15 (mainline kernel), so I assume the graphics driver are not the problem.

6
  • That is likely a problem with your graphics driver. Can you switch from opensource/closed source to closed source/opensource and see if that fixes it? – Rinzwind May 2 '18 at 14:35
  • I just checked within my installation of 18.04, and I can switch between tty's from the login screen. This feature is still supported and enabled. Within your installation, what happens when you try to switch? Do any of them work? Are you able to switch after you've logged in? What if you log in, then lock the session, are you able to switch then? – 64pi0r May 2 '18 at 14:51
  • 1
    There is a bug of shortcut keys being disabled. Ping me if you can't fund it and I'll find it after work. – WinEunuuchs2Unix May 2 '18 at 15:11
  • 1
    @WinEunuuchs2Unix I have the same problem, see my question: askubuntu.com/questions/1037369/… Could you send me the link to the bug report so that I can help fix it? – Ethunxxx May 17 '18 at 14:01
  • 1
    I am also experiencing this problem. In my case it seems to not be a problem of keyboard shortcuts rather something with drivers or low level display issue. Also it happens only when there is only a login screen. If there is another logged in X11 session then using ctrl+alt+f3 works properly. Also for me what seems to be the problem is that it seems to attempt to switch but the display freezes on what the login screen was showing. If I press ctrl+alt+F1 then I get back to a working login screen. I have been trying to find a related ubuntu bug but was unable to. – Giorgos Gaganis Jun 19 '18 at 11:27
1

This appears to caused by a bug in gdm3: Bug #1758512 "No virtual terminals (CTRL+ALT+F?) when no user logged in; erratic behaviour when user logged in."

I'd recommend going to that link and clicking the button to mark yourself as affected by the bug.

0

I also had the same problem, But Ctrl + Alt + F6 seems to work on mine. EDIT: earlier, nothing worked as i tried with F2 and F3 and F4 and then gave up. But now once F6 worked well, others seem to work well again too.

0

I have also encountered the same problem, but it seems to have been resolved after I upgraded software packages by apt upgrade.

I'm sorry that I don't know which package upgrade is the reason for this problem. I listed the version changes of the packages in my computer before, but it was messy so I deleted it... Just try the newer version of packages to solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.