4

I don't see the setting for this anymore after switching to Gnome, but I don't want my laptop to sleep at all unless I close the lid. I can suspend via terminal and shut down just fine, but the screen remains on and doesn't even ask for password upon waking up from suspension/sleep(a different topic).

I've tried lots of different flavors and settings, but none of them seem to resolve this.

I have also tried using dconf-editor and going to /org/gnome/settings-daemon/plugins/power and making sure lid-close actions were labelled as 'suspend', still not working.

Any help would be greatly appreciated!

  • I run Xubuntu and it doesn't have that problem if you want to try. But of cource it has other problems- 1.PC will always suspend on lid closing while running on battery power. 2.If you just want your screen to be turned off when u close the lid, you have to select that option for both battery and AC power. After that, while the screen will turn off for AC power, it will still go sleep while on battery. – HattinGokbori87 May 3 '18 at 4:56
0

For Ubuntu 18.04 install GNOME Tweaks, then open the program and in power section turn off "Suspend when laptop lid is closed". Thats it.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.