I did an upgrade via terminal yesterday, everything seemed to work fine but then I noticed very heavy CPU usage by gnome-shell. The problem is that the UHD card is not fully recognized, so it uses instead llvmpipe, so no native 3D acceleration :-( This was working great in 17.10

Some outputs which might be useful:

sudo lspci -nnk | grep -i vga -A3 00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) Subsystem: Dell UHD Graphics 620 [1028:07e6] Kernel driver in use: i915 Kernel modules: i915

glxinfo | grep llv Device: llvmpipe (LLVM 6.0, 256 bits) (0xffffffff) OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)

Pls let me know if providing more info would help. I am not sure if the driver is missing or if XORG is broken, please help. I am using XORG at the moment, Wayland freezes (it was working in 17.10).

Thanks!

  • I found the solution at askubuntu.com/questions/908381/… Basically, type systemctl --user unset-environment LIBGL_ALWAYS_SOFTWARE and reboot, then glxinfo and system settings report the correct UHD renderer is being used ;-) The problem seems to be that at somepoint gui crashed and then the system set this variable to avoid using native 3D acceleration. – user2003706 May 3 at 8:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.