2

I followed the instructions in https://help.ubuntu.com/community/Xen. Well, the first two steps. After the reboot, I am presented with:

Loading Xen 4.9-amd_64 ...
WARNING: no console will be available to OS
Loading Linux 4.15.0-20-generic ...
Loading initial ramdisk ...

Nothing more.

Does anyone run Ubuntu as dom0 in Xen these days? This is on a new HP Z8 workstation with dual "silver xeon 4114" which should have all the requisite functions.

I am a bit concerned about the lack of much detail in the BIOS. About the only thing I can tweak is the Hyper-threading setting.

  • I did eventually stumble in the BIOS settings page to enable all the requisite hypervisor settings: hidden under "security" TAB. Unfortunately, the boot still failed in the same manner, so I have given up on trying to get this to work for now. XenServer did install and run, and Qubes-OS is running, so ubuntu should run as dom0. – amgems May 4 '18 at 1:56
  • Having the same problem and not solution yet, but it is helpful to add this to <code>/etc/default/grub</code>: 'GRUB_CMDLINE_XEN="noreboot". This stops the system to reboot after Xen fails. I did get error messages displayed I did not see before. Only disadvantage: you need to reboot manually. – CatMan May 10 '18 at 12:20
1

I ran into similar problems with an ASUS PRIME-B250M-C/CSM motherboard. I tweaked the UEFI settings: disable FastBoot enable CSM (compatibility support mode) and then the system pauses after the above boot messages, but then gets Ubuntu-18.04 server started.

Also, note that the Xen kernel does not expose EFI variables to Dom0, so efibootmgr(8) fails.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.