40

This is with a fresh installation of Ubuntu 18.04 using the default GNOME Desktop.

The "tray icons" simply don't appear in the top panel. "Ubuntu appindicators" shell extension is active, but doesn't show any icons.

I've tried both the "kstatusnotifieritem" and "topicons" shell extensions without any success.

If anyone could help I would appreciate it.

2
  • Are you using Wayland or Xorg? Are you maybe using the Communitheme? Because I'm having the same issue with Communitheme + Wayland, so I'm wondering whether that is the cause. – Attila Fulop May 2 '18 at 8:41
  • 1
    @AttilaFulop nope, using xorg with the default theme on a fresh install. – ssjgs82 May 2 '18 at 21:12
49

What I did was:

  1. sudo apt purge indicator-common
    
  2. Then you can enable either the TopIcons Plus or Ubuntu AppIndicators extension

  3. Reboot the system or instead you could just reload the Gnome Shell with Alt+F2, then R.

Then you would be able to see the icons on the GNOME's bar.

7
  • I also wanted to point out that this worked on my system as well. All my tray icons are back. Not sure what the cause is. A conflict? – Sepehr Jun 5 '18 at 18:45
  • 1
    where is this "Ubuntu AppIndicators" extension? I can't find it anywhere at all – cat Aug 4 '18 at 22:55
  • 6
    No need to reboot system -- as simple Gnome Shell reload seems to do the trick (Alt-F2, type r, press Enter). – mortenpi Aug 22 '18 at 23:20
  • 1
    Worked for me too, thanks :) Ubuntu AppIndicators can be enabled/disabled with gnome-tweaks – OndroMih Jan 11 '19 at 17:39
  • Works on 19.04, too. Leftover packages from the Unity days, it appears. – Adam Israel Mar 29 '19 at 3:51
15

You don't have to uninstall ubuntu - appindicator. Just turning on ubuntu - appindicator first in gnome-tweak, and then install topicon plus, there are no problems.


Edit:

If you don't have it already, install the package gnome-tweaks.

Run "gnome-tweaks" and look at the 4th item called "Extensions". Looks like this:

enter image description here

Make sure you enable Kstatusnotifieritem/appindicator support.

4
  • 5
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) – David Foerster Jul 23 '18 at 17:12
  • I was missing this one – Amanuel Nega Jan 1 '19 at 9:07
  • Also needed to install Topicons (not pluss), installed through normal Ubuntu Software – Ole Henrik Skogstrøm Feb 19 '19 at 9:51
  • This is the right answer! Thanks! – Ryan Jan 2 '20 at 17:31
8

Based on the other answers, the combination that worked for me was

  1. purge indicator-common: sudo apt purge indicator-common. This also removes the unity desktop. That was still present on my system after upgrading from ubuntu 16.04, but has been discontinued now.

  2. install Ubuntu AppIndicators: sudo apt install gnome-shell-extension-appindicator

  3. Restart gnome-shell: gnome-shell --replace &. This will restart gnome-shell from a terminal and run it in the background.

  4. Open gnome tweaks (see mifjpn's answer) and enable the Ubuntu appindicators extension. If it is not visible you may need to restart gnome tweaks and/or gnome-shell.

  5. Restart gnome-shell again: gnome-shell --replace &. Then (optionally) do disown %1 after that to detach the process from the terminal so you don't accidentally kill gnome-shell if you close the terminal.

After the second restart the indicators finally became visible. I'm a bit disappointed that after installing the package I need to restart gnome-shell twice, first to make the extensions visible in gnome tweaks so I can enable them, then to actually run them. (This might be because only the second restart starts my applets that use an indicator.)

NB. I don't have the TopIcons extension installed.

4

I just installed 18.04 and found this issue. The only way to reliably show all tray icons is to first install Top Icons plus and then proceed to uninstall gnome-shell-extension-appindicator (run sudo apt purge gnome-shell-extension-appindicator)

After a restart (or maybe just logging out) you'll see all tray icons, make sure you go through the settings of that extension to make it work the way you want to, but even if you don't it should be working. It took me a while to fix this.

2
  • 1
    I tried that command, but it wants to remove ubuntu-desktop as well. It's the same for gnome-shell-extension-ubuntu-dock. ubuntu-desktop seems like an important package and many packages depend on it, so I'm not going to try it. – MWin123 Jul 15 '18 at 2:10
  • @MWin123 you can install the 'gnome-tweak tool' and disable the existing app-indicator and replace it with the 'top-icon plus' i guess. – Ajith R Nair Jul 19 '18 at 13:20
4

In 18.04 the Topicons (not plus) needs to be on as well as the Ubuntu app indicator which comes by default. I didn't need to uninstall anything though a notification came on requiring a restart. I guessed it was a gnome restart and so did alt-f2 and pressed 'r'. I did a reboot and there was a notification to log out as well so I did that plus a reboot for luck and all seems good.

2

Other solutions did not work for me. What did it was to install gnome system-monitor-applet:

  1. Install gnome-system-monitor:

    sudo apt install gnome-system-monitor
    
  2. Install system-monitor extension dependencies as suggested in https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet :

    sudo apt install gir1.2-gtop-2.0 gir1.2-networkmanager-1.0  gir1.2-clutter-1.0
    
  3. Install gnome system-monitor extension here: https://extensions.gnome.org/extension/120/system-monitor/

  4. Reload gnome: ALT+F2, then type r, then Enter

Result:

enter image description here

2

Warning: TopIconsPlus is no longer supported and I do not recommend it!

see https://github.com/phocean/TopIcons-plus

In my case (Mattermost and Shutter applications) solving the problem with the icons in the system tray requires a libgtk2-appindicator-perl package which was removed from Ubuntu 18.04 main repository.

Workaround: sudo apt-get install libappindicator-dev

1
  • I found that solution as well, but decided not to go that path, as it seems a bit like killing a fly with a sledgehammer; so many other packages get installed with this - 128mb in all - that it seems a bit of overkill to be used as a 'solution' to something as elementary as getting the app to show up in the tray. – HockeyBum Apr 28 '19 at 18:28
-2

my App Indicator wasn't working -- icons were there but unresponsive, I switched from wayland to xorg and it fixed the problem (so far)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.