0

Here is what I did: enter image description here

  • I disabled "Keep system layouts" in settings.
  • Added my secondary language (Arabic) to keyboard layouts.
  • Modified the layout change keys to: "Alt+Shift" and "Left Alt+Left Shift".

My (right) "Alt+Shift" keys successfully change the language from English to Arabic but never back! Left Alt+Left Shift are working just fine.

Being right-handed I really need to get the right Alt+Shift keys to successfully swap between the two input languages.

OS: Lubuntu 18.04 x64 - I clean-installed it today.

  • How did you even get the screen shot? I don't have this thing called the keyboard layout hander. Did you install it from somewhere? – itsols Jul 19 '18 at 6:09
  • @itsols It is a panel applet. You can add it to your panel. imgur.com/download/PQN9jI7 – Ebram Shehata Jul 20 '18 at 3:42
1

When the Arabic layout is effective, Right Alt is defined (by default) as the key to access 3:rd and 4:th level symbols. That's probably the reason why you can't use it to switch back to English.

You have two options. Either

  • start using some other shortcut for switching layouts, or
  • explicitly define some other key but Right Alt to access 3:rd and 4:th level symbols.
  • But I used to use the same software with same shortcut without any problems! – Ebram Shehata May 2 '18 at 0:26
  • @EbramShehata: It's hard for me to comment on that. I think you'll notice a difference if you add lv3:ralt_alt to the list of layout options. But then you won't be able to access 3:rd and 4:th level symbols on the Arabic layout. For that you need yet another option; which one depends on which key you want to use for the purpose. – Gunnar Hjalmarsson May 2 '18 at 0:40

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.