0

I've recently tried to install Ubuntu 18.04 LTS on Oracle VM VirtualBox, cause I wanted to give this version of Ubuntu a chance. So far, I was using Ubuntu Mate 16.04 which caused no trouble at all.

The first thing I noticed with Bionic Beaver was that the input lag is particularly high: I know the virtualization slows down the operating system, but it was not this much on Mate desktop environment. After some testing, I came up with these results on the two platforms:

  • ~ 0.15 seconds of input lag with Mate desktop when using text editors like VSCode or Atom
  • ~ 0.30 seconds of input lag with Gnome desktop on the same programs, and even on the default terminal

My question is:

  • is it possible that all the difference is related to the desktop environment I use?
  • if so, is there any tricky way to sensibly reduce the input lag (maybe without changing environment :P) ?

Further details

  • Dell XPS 13 9370 on Windows host
  • Both run with 4 processors, 4GB of RAM, 64MB for graphics and 3D Video Acceleration enabled

...and yes, I've tried out VMWare and the differences still remain.

1
  • I can confirm your discoveries, but it is expectable with all bells and whistles of modern GNOME. It eats whole RAM and CPU :) If you need to do your work - use MATE DE. Or Xfce, or LXDE. – N0rbert May 1 '18 at 21:02
0

I'd recommending using virt-manager and kvm-qemu as this seems to always be more responsive and snappier than VirtualBox for the virtual machines that I run on my x86 hardware. I believe the virtualization is possibly more efficient with this than VirtualBox, but it depends on your hardware and what is being virtualized and/or emulated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.