0

Ubuntu 18.04 LTS cannot be installed on Dell Inspiron 15 5000 gaming laptop with GeForce GTX 1050 Mobile. The screen goes blacklight and freezes and the installer does not run.

There are another very similar questions, but too old, In my case am trying to install Ubuntu 18.04 with release date 4/26/2018, it is too fresh, What can I do, any advice?

  • The answers are very similar, but my question was about Ubuntu 18.04 LTS. This version has only one week, it is very recent. I tried to put the problem very specific for the latest version of Ubuntu. In my answer below I put other solution sources. But thanks for your comment. – hermeslm May 4 '18 at 3:56
1

After several days trying to solve the problem, I found this post explaining some solutions, it seems that the kernel that is using Ubuntu 18.04 has some problems with the Nvidia cards.

  1. Using this option "nomodeset" by editing the properties of the bootable USB, this can be done by pressing the letter "e" when the advanced menu of the Grub appears:

enter image description here

You can check how this can be done too in this other post.

  1. In step 1 I managed to boot the Ubuntu installer and I was able to install correctly.
  2. When the installation is finished, and the system is rebooted, it is not booting from the hard disk, then doing the same process used for the USB installer but in this case, using the option "acpi=off" Ubuntu booted without problems in my laptop Dell Inspiron 15 5000.
  3. The last step is to make persistent this change in Grub config file avoiding to do this process every laptop boot.

You must edit this file:

sudo nano /etc/default/grub

and then add "acpi=off" to GRUB_CMDLINE_LINUX_DEFAULT:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
GRUB_CMDLINE_LINUX=""

And then save by hitting Ctrl+O, then exit nano with Ctrl+X, then simply run:

sudo update-grub

Final Solution and last step:

Due to the risk of disabling the acpi=off, because this controls everything related to temperature sensors, fan speed I tried a final option:

sudo ubuntu-drivers autoinstall

This installs all the default drivers including the Nvidia driver in my case with the version: nvidia-driver-390

When you do the reboot, the laptop does not do the booting, but do not worry, let doing the same procedure to pass parameters to the kernel but this time we remove the "acpi=off" and we put "nvidia-drm.modeset=1". We get out the grub edition and the laptop works correctly again but with all the functionalities that in my case were disabled as the battery sensor percent and others.

Now finally we have to make this persistent change in the grub configuration file, the final result will be this:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvidia-drm.modeset=1"
GRUB_CMDLINE_LINUX=""

Save and close and do this last command:

sudo upgrade-grub

Reboot the laptop and everything will work perfectly. This solution was found here.

So enjoy your fresh Ubuntu 18.04 LTS installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.