1

I'm trying to install wine on Ubuntu Mate 18.04. Whenever I add the repository I get the error message

Blockquote E: The repository 'http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu bionic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

It's given the same error message for a few other programs I've tried to install too. Is it because 18.04 is so new it doesn't officially support it yet?

  • 3
    The error message means exactly what it says - the ppa does not support 18.04, in fact it does not support 17.10 either and at the ppa's webpage there is a message that says: !!! PLEASE NOTE THAT THIS REPOSITORY IS DEPRECATED !!! – karel May 1 '18 at 16:50
4

18.04 has been out for less than a week. As such, many developers haven't caught up to the new release yet. To that end, WineHQ has a bug for this already requesting 18.04 packaging in their repository.

There is Wine 3.0 in the Ubuntu repositories, you can use that in the interim by executing sudo apt install wine. Once the upstream WineHQ repositories catch up you can use them.

Once that time is available, you can follow the instructions for installing from their repos. From their instructions page are the instructions to follow at that time:

If you have previously installed a Wine package from another repository, please remove it and any packages that depend on it (e.g., wine-mono, wine-gecko, winetricks) before attempting to install the WineHQ packages, as they may cause dependency conflicts.

If your system is 64 bit, enable 32 bit architecture (if you haven't already):

sudo dpkg --add-architecture i386 

Add the repository:

wget -nc https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

Update packages:

sudo apt-get update

Then install one of the following packages:

Stable Branch:

sudo apt-get install --install-recommends winehq-stable

Development Branch:

sudo apt-get install --install-recommends winehq-devel

Staging Branch:

sudo apt-get install --install-recommends winehq-staging

If apt-get complains about missing dependencies, install them, then repeat the last two steps (update and install).

Staging isn't really used anymore, so use either Stable or Devel.

There will be differences though:

  • Files are installed to /opt/wine-devel.

  • Menu items are not created for Wine's builtin programs (winecfg, etc.), and if you are upgrading from a distro package that had added them, they will be removed. You can recreate them yourself using your menu editor.

  • Binfmt_misc registration is not added. Consult your distro's documentation for update-binfmts if you wish to do this manually.

  • WineHQ does not at present package wine-gecko or wine-mono. When creating a new wine prefix, you will be asked if you want to download those components. For best compatibility, it is recommended to click Yes here. If the download doesn't work for you, please follow the instructions on the Gecko and Mono wiki pages to install them manually.

  • Thanks. I can't download from those repositories though, because I get the same "no valid release file" error message. – Weboh May 3 '18 at 20:20
  • @Weboh 18.04 right? – Thomas Ward May 3 '18 at 20:22
  • 1
    Yep. Is it just so new it's not supported? I'm about ready to install Xenial. – Weboh May 3 '18 at 21:05
  • @Weboh I am also having the same vice as you; The system upgrade has only been out for mere days, the wonderful people over at winehq need a bit of time to update their releases. I expect it should be out in the next week if not sooner. – DirkyJerky May 4 '18 at 0:15
  • @Weboh and all: This is a known issue on WineHQ's bugs/issue tracker - bugs.winehq.org/show_bug.cgi?id=45085 - and there hasn't been much move on it yet. The issue is that Ubuntu 18.04 is less than a week old and in turn is "so new" that upstreams haven't yet adopted it on build platforms. I would track the Wine Bug until we know it's available. In the interim, I believe there's Wine 3.0 in the repositories you can use - once the WineHQ repos have 18.04 releases you can switch to that. – Thomas Ward May 4 '18 at 1:04
0

I suggest just installing wine-stable from the Ubuntu repos. They have verison 3.0-1ubuntu1 which is pretty up to date.

Remove any wine-related ppas you have installed and give the command

sudo apt install wine-stable

  • Thanks. I thought I was using the official repo before... Anyway, how can I completly remove the old installation? I removed all the packages using Synaptic and deleted the .wine directory in my home folder but mate-menu still shows a wine submenu when it's supposedly not installed. And when I reinstall wine, it doesn't work correctly (and there's no wine-config entry in mate-menu, though the wine submenu with programs installed with the old wine installation is still there...). – Weboh May 3 '18 at 19:04
  • I don't know MATE but on my LXDE-over-Ubuntu installs wine leaves a lot of trash entries in /home/[user]/.local/share/applications There must be 30 entries in there for Windows Media Player! You could check there and clean out wine related stuff. – Organic Marble May 3 '18 at 19:20
  • Just an FYI, but if you want the 'latest' stable Wine you should be using their repos (which I touch upon in my answer). the PPA doesn't anymore and is actually deprecated in favor of WineHQ's repos. – Thomas Ward May 3 '18 at 19:42
  • 1
    Cool cool, I'm just making a note. Stable Wine is 3.0, but once they release a new 'Stable" release they start calling the older stable releases "no longer supported". – Thomas Ward May 3 '18 at 19:46
  • 1
    Actually 3.0 is no longer listed on the AppDB as a supported version, so it's interesting to note that 3.0 might be "too old" now... – Thomas Ward May 3 '18 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.