From my old HD (Ubuntu 16.04) I copied ~/.thunderbird and other programs to the new disk with Ubuntu 18.04 installed.
All went good.
I tried to install Opera. The installation was unsuccessful, a window asking something was held.
After that Thunderbird Local Folders -> Inbox (only) was invaded by large icons like this screenshot
enter image description here
Flowers, plants, trucks and others.
I restarted but those images are still there.
Opera was successfully installed. What can I do to remove them?

up vote 40 down vote accepted

This fixed it for me:

sudo apt-get install fonts-symbola

but turns the icons b/w!

From https://ubuntu-mate.community/t/thunderbird-with-huge-icons-emoticons-mate-18-04/16249/23

Here's a way of getting colored icons:

sudo apt-add-repository ppa:eosrei/fonts
sudo apt-get update
sudo apt-get install fonts-twemoji-svginot

I did not have to uninstall fonts-symbola for this to work but I don't know how Thunderbird decides which to use.

New font info from http://www.omgubuntu.co.uk/2016/08/enable-color-emoji-linux-google-chrome-noto

  • 1
    remark: the issue goes away, and so does your colored emojis! (they are the right size, but black and white now). Would be nice to be able to keep colored emoji... – Sulliwane May 12 at 20:32
  • @Sulliwane thank you for pointing that out - I hadn't noticed! Have edited my original answer to include a color font. – B.Tanner May 17 at 16:57
  • i like the message: Only Mozilla Firefox/Thunderbird currently support the SVG-in-OpenType font format required to display these fonts in color. All other applications will display the included backwards/fallback compatibility B&W outline glyphs. More details: github.com/eosrei/twemoji-color-font End Of Life: github.com/eosrei/emojione-color-font More info: launchpad.net/~eosrei/+archive/ubuntu/fonts Press [ENTER] to continue or Ctrl-c to cancel adding it. – rémy May 29 at 7:14
  • and I need to say, this that this font hurts my eyes somehow .. need to play around with the settings in thunderbird .. – rémy May 29 at 7:15
  • 1
    I like black and white - it's less intrusive. So the first line only helped me already. Ideally, I'd find a way to block these things from appearing in subjects completely. – Alexander Engelhardt Aug 29 at 7:07

While not a long-term solution (but should work until the fix for the bug is deployed), you can install the EditEmailSubject add-on for Thunderbird. It will allow you to delete offending characters from message subjects.

I find the add-on useful generally so this works for me.

To fix this I downloaded the

NotoEmoji-Regular.ttf

from here: https://github.com/googlei18n/noto-emoji/tree/master/fonts

and copied it to

/usr/share/fonts/truetype/noto

(sudo was required)

then restarted Thunderbird and everything was fine.

References: https://support.mozilla.org/en-US/questions/1178430

protected by Community Sep 5 at 17:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.