0

i'm trying to install ms sql server on ubuntu desktop 18.4 but i get what follows:

luca@SQUARE:~$ sudo apt-get install mssql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mssql-server : Depends: openssl (<= 1.1.0)

E: Unable to correct problems, you have held broken packages.

i tried to downgrade openssl using aptitude as suggested in Installation problems with MS SQL server for linux but i get the message "No more solutions available".

moreover, manually downgrading openssl by

luca@SQUARE:~$ sudo dpkg -i openssl_1.0.1-4ubuntu5.31_amd64.deb
dpkg: warning: downgrading openssl from 1.1.0g-2ubuntu4 to 1.0.1-4ubuntu5.31
(Reading database ... 127965 files and directories currently installed.)
Preparing to unpack openssl_1.0.1-4ubuntu5.31_amd64.deb ...
Unpacking openssl (1.0.1-4ubuntu5.31) over (1.1.0g-2ubuntu4) ...
Setting up openssl (1.0.1-4ubuntu5.31) ...
Installing new version of config file /etc/ssl/openssl.cnf ...
Processing triggers for man-db (2.8.3-2) ...

lead anyway to an installation failure:

luca@SQUARE:~$ sudo apt-get install mssql-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 ca-certificates : Depends: openssl (>= 1.1.0)
 mssql-server : Depends: libjemalloc1 but it is not going to be installed
                Depends: libc++1 but it is not going to be installed
                Depends: libcurl3 but it is not going to be installed
                Depends: python (>= 2.7.0) but it is not going to be installed
                Depends: libsss-nss-idmap0 but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

can somebody help me about it?

thanks in advance.

EDIT :

as suggested by N0rbert, this is the output of "apt-cache policy mssql-server":

luca@SQUARE:~$ apt-cache policy mssql-server
mssql-server:
  Installed: (none)
  Candidate: 14.0.3025.34-3
  Version table:
     14.0.3025.34-3 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.3023.8-5 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.3022.28-2 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.3015.40-1 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.3008.27-1 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.3006.16-3 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages
     14.0.1000.169-2 500
        500 https://packages.microsoft.com/ubuntu/16.04/mssql-server-2017 xenial/main amd64 Packages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.