2

I have just upgraded from Ubuntu MATE 16.04 LTS to Ubuntu MATE 18.04 LTS (via sudo do-release-upgrade).

The system UI language is English, but I have a non-US keyboard and selected the corresponding layout when I installed 16.04. Ubuntu MATE 16.04 would use that keyboard layout everywhere (tty, login screen, GUI user session). After the upgrade to 18.04, the login screen has the US layout and I have to select my local layout each time I boot the machine. The GUI user session and the tty (even at the login prompt) use the local layout by default.

How can I change the keyboard layout for the GUI login? Is this a bug in 18.04?

Contents of /etc/default/keyboard:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT="legacy"
XKBOPTIONS=""

BACKSPACE="guess"
  • 1
    Can you please edit your question and show us what the command cat /etc/default/keyboard outputs. – Gunnar Hjalmarsson May 1 '18 at 14:01
  • Done, see above – user149408 May 1 '18 at 17:04
2

There does not exist any de+legacy keyboard layout variant. I suggest that you open /etc/default/keyboard for editing and change the line

XKBVARIANT="legacy"

to

XKBVARIANT=""

Hopefully that will make the German layout show up on the login screen.

Edit:

Actually de+legacy did exist in Ubuntu 16.04, but it was renamed to de+deadtilde. So to retain exactly the same keyboard behavior, the line should read:

XKBVARIANT="deadtilde"
  • Thanks, that did the trick. Still odd that I would have this non-existent combination in my config, as I never touched that file before. I have another machine to upgrade—I will check the file there before I upgrade and report back. – user149408 May 1 '18 at 18:09
  • I’ve now upgraded the other machine, which already had XKBVARIANT="" before the upgrade and did not require intervention afterwards. – user149408 May 3 '18 at 12:52
  • @user149408: My dealing with bug #1768556 was enlightening; please see my edited answer. – Gunnar Hjalmarsson May 3 '18 at 14:18
  • Oh, there’s my bug again (btw, thanks for the quick resolution :-). However, the second machine definitely had the dead tilde behavior pre-upgrade. Apparently, in addition to the rename, the behavior of de changed as well. – user149408 May 3 '18 at 15:01
  • @user149408: Was that your bug? ;) Then I'd suspect that "legacy" was set previously in the user specific keyboard settings on the second machine. /etc/default/keyboard provides system wide defaults. – Gunnar Hjalmarsson May 3 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.