2

As you can see there is no option for enabling edge scrolling in Ubuntu 18.04. Now I can only scroll with two fingers, which it sucks.

How can I enable edge scrolling in Ubuntu 18.04?

enter image description here

2

It seems you didn't install whole packages, or packages are not up-to-date

install the following package:

apt update
apt install xserver-xorg-input-libinput

Or install and upgrade whole ubuntu packages this way

open a terminal and type

apt update
apt install ubuntu-desktop

if nothing happened generate new /etc/apt/sources.list from this link and repeat steps above

If still you have the problem mayble you need a full upgrade:

apt update
apt full-upgrade

after package steps you can enable it, this way:

Settings > Mouse & Touchpad > "Uncheck" Two finger scroll

Settings screenshot:

Edge Scrolling setting

OR:

Settings > Devices > Mouse & Touchpad > Edge Scrolling

Enabled Edge Scrolling setting

This is also accessible via DConf Editor as well. Go to org.gnome.settings-daemon.peripherals.touchpad and set:

 scroll-method: edge-scrolling

edge-scrolling

  • 1
    It's possible OP question is about Ubuntu Unity and your answer is about Ubuntu Gnome? – WinEunuuchs2Unix May 31 '18 at 10:40
  • 1
    18.04 upgraded from 16.04 provides both Unity and GDM. The OP's screen shot looks like Unity to me. – WinEunuuchs2Unix May 31 '18 at 12:34
  • I changed it a little bit, and add both Mouse & Keyboard Settings – scarface_90 Jun 1 '18 at 11:16
1

If using a unity session then you need to install xserver-xorg-input-synaptics package, ie. sudo apt install xserver-xorg-input-synaptics

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.