1

I can't adjust brightness

I've got a MSI GT72VR laptop with ONLY 1 graphic card, a NVIDIA GeForce GTX 1060 Mobile and 2 audio card, a NVIDIA GP106 and a Intel CM238.

The problem is that I can't adjust the brightness of my screen. Always is 100%. I've got Ubuntu 18.04 clean install and nouveau drivers (Xorg.org) enter image description here

There aren't brightness slider at the top of bar:

brightness slider

Also, the keys Fn + Bright Up and Fn + Bright Down doesn't do anything

Things I've already tried that don't work [1 May 2018]

  • Change driver to NVIDIA driver 390
  • Install and use redshift, xbacklight Link
  • Edit with sudo vi /etc/default/grub
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=native"
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=video"
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
  • And then update-grub and reboot Link Link

Output for some commands

lspc | grep NVIDIA:

01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1) 
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)

ll /sys/class/backlight:

total 0
drwxr-xr-x  2 root root 0 may  1 12:32 ./
drwxr-xr-x 67 root root 0 may  1 12:10 ../

dmesg | grep -i vga:

[    0.148024] pci 0000:01:00.0: vgaarb: setting as boot VGA device
[    0.148024] pci 0000:01:00.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[    0.148024] pci 0000:01:00.0: vgaarb: bridge control possible
[    0.148024] vgaarb: loaded
[    0.969601] fb0: EFI VGA frame buffer device
[    1.349219] fb: switching to nouveaufb from EFI VGA
[  543.049571] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client

uname -a:

Linux laptop 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

journalctl -b | grep -i nvidia:

may 01 12:19:27 laptop kernel: nouveau 0000:01:00.0: NVIDIA GP106 (136000a1)
may 01 12:19:28 laptop kernel: input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input16
may 01 12:19:28 laptop kernel: input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
may 01 12:19:33 laptop /usr/lib/gdm3/gdm-x-session[1171]: (II) NOUVEAU driver for NVIDIA chipset families :
may 01 12:19:33 laptop /usr/lib/gdm3/gdm-x-session[1171]: (--) NOUVEAU(0): Chipset: "NVIDIA NV136"
may 01 12:19:38 laptop /usr/lib/gdm3/gdm-x-session[1171]: (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event15)
may 01 12:19:38 laptop /usr/lib/gdm3/gdm-x-session[1171]: (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event16)

inxi -SMCGAx:

System:    Host: laptop Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Gnome 3.28.1 (Gtk 3.22.30-1ubuntu1) Distro: Ubuntu 18.04 LTS
Machine:   Device: laptop System: Micro-Star product: GT72VR 7RD v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-1785 v: REV:1.0 serial: N/A
           UEFI: American Megatrends v: E1785IMS.30E date: 10/27/2017
CPU:       Quad core Intel Core i7-7700HQ (-MT-MCP-) arch: Skylake rev.9 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
           clock speeds: max: 3800 MHz 1: 1046 MHz 2: 3165 MHz 3: 3164 MHz 4: 3139 MHz 5: 3093 MHz 6: 3190 MHz
           7: 3056 MHz 8: 3046 MHz
Graphics:  Card: NVIDIA GP106M [GeForce GTX 1060 Mobile] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: fbdev,nouveau (unloaded: modesetting,vesa)
           Resolution: 1920x1080@120.00hz
           OpenGL: renderer: NV136 version: 4.3 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card-1 Intel CM238 HD Audio Controller driver: snd_hda_intel bus-ID: 00:1f.3
           Card-2 NVIDIA GP106 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic

sudo lshw -C display:

  *-display                 
       description: VGA compatible controller
       product: GP106M [GeForce GTX 1060 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:131 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:c0000-dffff
0

I have an Asus GL502VM with Nvidia 1060 and a gsync display. I faced the same issue, haven't found a permanent fix but the workaround from here worked for me. In order to use it you need to install the nvidia driver instead of xorg one and modify the DP-0 value according to your setup, in my case according to xrandr --verbose my display is connected to DP-2 port. Also night light option will change the brightness level so I disabled it.

Brightness seems to be working in unity on 18.04 though.

The bug is reported https://bugs.launchpad.net/ubuntu/+bug/1767001

0

Try acpi_osi=

On upgrading to Bionic today, I encountered the same problem (same graphics card and the same problem with an empty /sys/class/backlight).

In working through the backlight debugging procedure, I discovered a workaround via kernel parameters. Mimicking your instructions above:

  • Change driver to NVIDIA driver 396.
  • Edit with sudo vi /etc/default/grub:
    • GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
  • And then sudo update-grub and reboot.

(Bug reported here.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.