99

How do I turn off the Ubuntu error sound (especially on the terminal) in Ubuntu 18.04?

4
  • Try this: askubuntu.com/questions/26068/…
    – valiano
    May 1, 2018 at 14:37
  • 7
    Got to System-settings->Sound->Sound Effects->Alert volume and turn the switch to OFF. May 1, 2018 at 17:26
  • I have a related problem: I can't stand Ubuntu 18's terminal bell, but following this advice, I realize the sound has two components: a) the one selected in "Sound Effect", and, b) a deep, practically booming reverb of the selection. I want to keep the first sound, but kill the reverb. Not only is it jarring, but in the lab where I work it is annoying to others, because it really carries. (Should I make this it's own question?)
    – Dan H
    Oct 9, 2019 at 18:42

6 Answers 6

85

In order to turn off Ubuntu error sound in Ubuntu 18.04 you need to go Setting > Sound > Sound Effects > Alert Volume > Off.

Sound settings dialogue

6
  • 10
    it is good to know there is even bark.. Aug 31, 2019 at 1:48
  • 2
    This alert control seems to not exist on Ubuntu 19.10. The solution given by Nick Hope does work, though Jan 18, 2020 at 13:09
  • 1
    YES! This option mutes all of the alert sounds I constantly have whenever I'm holding down Backspace to remove a few characters in the text input field. Finally, no more constant alert sound effects in my headphones. Feb 1, 2020 at 21:39
  • @dgallant You have obviously never used Puppy Linux
    – user927600
    Apr 17, 2020 at 6:44
  • 2
    Ubuntu 20 has removed this option :| This is really annoying in the text editor.
    – aderchox
    Jul 18, 2020 at 16:17
64

If you just want to turn off on terminal in Ubuntu 18.04, open Terminal > Edit > Preference then choose your terminal profile and uncheck Terminal Bell

enter image description here

1
  • 3
    Thanks, this should have been the accepted solution! Oct 11, 2020 at 5:24
38

Add the following line to the bottom of your ~/.bashrc file:

bind 'set bell-style none'

New terminals will have no error sound.

2
14

For turn off terminal sound you need go to terminal, then go to tab edit > preferences and uncheck terminal bell.

3

Run this command in the terminal:

dconf write /org/gnome/desktop/sound/event-sounds "false"
0
0

Either edit /etc/inputrc (system wide) or ~/.inputrc

and add the line:

set bell-style none

(it might just be commented out)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .