3

I'm new to Linux, been using it for less than a year. Loving it so much, accept of the fact that I have no sound on my laptop.

It seems to be a known bug concerning Intel sound card and Pulseaudio. Had it on previous version - Xubuntu 16.04, and tried to use the patch, but it's a bit too complex for me. Was kind of hoping that the new Xubuntu LTS version will fix this, but nothing happens.

As I've said - there is no sound whatsoever. The sound icon on the panel is gray, and when I open it - the mute box is checked, and I cannot UN-check it. Also, when I try to open PulseAudio Volume Control (from the Multimedia menu) it says Establishing connection to Pulseaudio. Please wait... - and nothing happens.

Here are my System Info

Host: neumatta Kernel: 4.15.0-20-generic x86_64 bits: 64 Desktop: Xfce 4.12.3
       Distro: Ubuntu 18.04 LTS
Machine:   Device: laptop System: ASUSTeK product: E200HA v: 1.0 serial: N/A
       Mobo: ASUSTeK model: E200HA v: 1.0 serial: N/A
       UEFI: American Megatrends v: E200HA.207 date: 02/01/2016

CPU:       Quad core Intel Atom x5-Z8300 (-MCP-) speed/max: 480/1840 MHz
Audio:     Card Intel HDMI/DP LPE Audio driver: HdmiLpeAudio Sound: ALSA v: k4.15.0-20-generic

Any help is more than welcomed. But do have in mind I need step-by-step help :)

Thanks in advance!

  • Does it help when you run the command pulseaudio --start in a terminal? – mook765 May 1 '18 at 10:11
  • Nothing. N: [pulseaudio] main.c: User-configured server at {a968a0ccce2844809f38ee0f2d3b8cce}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper. – Neu Matta May 1 '18 at 10:34
  • Could you please edit your question to include the output of the terminal commands lspci -nnk | awk -v n='[0403]' 'p&&/^\S/{p=0}!p{p=index($0,n)}p', aplay -l, and pactl list short sinks? Please also make sure that the relevant audio channels in alsamixer (terminal) or gnome-alsamixer (GUI) have their volume turned up and aren’t muted. Thanks. – David Foerster Jul 7 '18 at 15:20
3

I have had the same problem after each restart. I don'n know clear solution, but workaround.

$ ps -ef | grep pulse
gdm       1293  1164  0 11:12 ?        00:00:00 /usr/bin/pulseaudio --daemonize=no
root      1460     1  0 11:12 ?        00:00:00 /bin/sh /snap/pulseaudio/9/bin/pulseaudio
root      1687  1460  0 11:12 ?        00:00:00 /snap/pulseaudio/9/usr/bin/pulseaudio --exit-idle-time=-1 --disallow-exit=yes --system -F /snap/pulseaudio/9/etc/pulse/default.pa -p /snap/pulseaudio/9/usr/lib/pulse-8.0/modules -n
haripra+  3268  2078  3 11:15 ?        00:00:08 pulseaudio --start
haripra+  3578  3257  0 11:20 pts/0    00:00:00 grep --color=auto pulse

If I kill (e.q. $sudo -kill 1460 etc.) the processes, Pulse audio started, bu still even if the connection from pulse to the sound HW is established, Pulse not know about streams and applications.

In the Settings, test speakers works, but there is still no sound. After restart, the problem is back.

According this page Establishing connection to PulseAudio. Please wait ...

$ pulseaudio --check
$ pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.

1) Reinstall PulseAudio and Alsa libraries according for examamle here: No Sound In Ubuntu And Linux Mint

In fact i used different way - Synaptic package manager. Install Pulse Audio Volume Control.

2) Delete in your home ~/.config/pulse directory. This is the key step.

3) Restart system.

Don't try

To change manually anything on this Tab:

enter image description here

Attend to change configuration causes, that there will be again the same problem described above and you must repeat step 2) and 3).

Also to check sound in Settings -> Sound Test speakers probably doesn't work. But streans are visible (Applications Tab) and sound is back.

enter image description here

1

I recently upgraded to Xubuntu 18.04 LTS and didn't have any audio either.

I researched the relationship between Alsa and Pulseaudio which was very helpful. I purged and reinstalled alsa and PulseAudio as suggested above. Went to Alsamixer in a terminal and saw that the speakers were turned up full. PulseAudio Volume Control was already installed, so I played a YouTube video and in PulseAudio Volume Control I could see the audio and adjust its level. Still no luck.

Then I started going through the tabs in PulseAudio Volume Control. When I went to the tab called Output Devices, I noticed 3 little icons in the upper right-hand corner. One of them looked like a button making sound waves, and it seemed grayed out. I clicked it, and lo and behold: Sound! The Speaker output device was muted! Why it would ship with the speakers muted I can't guess, also I went through so many other places it could have been muted by some other program. Dunno.

Image showing the mute icon in upper right of Output Device tab

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.