5

My system stuck at ubuntu logo while booting. To resolve it, I've set nomodeset.

But now it occurs a resolution issue to 1024x768. Here are the necessary information:

lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)
    Subsystem: Hewlett-Packard Company 82945G/GZ Integrated Graphics Controller [103c:302a]
    Kernel modules: i915, intelfb

and

xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

Output of

$ cat /proc/cpuinfo | grep -w 'model name'
model name  : Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz

Output of sudo lshw -c display

*-display UNCLAIMED       
       description: VGA compatible controller
       product: 82945G/GZ Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:e2000000-e207ffff ioport:c000(size=8) memory:d0000000-dfffffff memory:e2080000-e20bffff memory:c0000-dffff

I've tried solution 1 and solution 2 but no success.

This issue occurred only after installing it, not when I choose 'Try without Installing', I don't need to set nomodeset in that case.

Intel Graphics Update Tool shows:

Checking if Intel graphics card available...
  • checking for i915 module in /sys/module
  • i915 module found
Checking if Intel graphics card available... OK
Retrieving information from 01.org...
  • fetching https://download.01.org/gfx/ilg-config.cfg
  • saving to /home/garden/.ilg-config
  • fetched 1626 bytes
  • fetched 9818 bytes
  • fetched 12301 bytes
  • looking up [Ubuntu bionic] configuration
Retrieving information from 01.org... OK
Checking distribution... Failed

Edit: I've installed xserver-xorg-video-intelandxorg-dev. I've tried acpi_osi=linux,acpi_backlight=vendor, noalpic, i915.modeset=0 also create xorg.conf file and modify file /etc/initramfs-tools/modules to add i915 and intel_agp drivers as mentioned here.

  • I guess it is necessary to use nomodeset. What graphics chip/card is it? I can see that it is Intel graphics, but which model? For some chips, it helps to install the package xserver-xorg-video-intel – sudodus May 1 '18 at 9:20
  • Sometimes it helps with #GRUB_TERMINAL=console ; Uncomment to disable graphical terminal. This may provide help if the GRUB 2 menu is too large or unreadable. It also may help when using the GRUB_HIDDEN_TIMEOUT feature. See this link – sudodus May 1 '18 at 9:24
  • @sudodus xserver-xorg-video-intel command not found and grub2 is not too large, it is readable but let me try once. – d a i s y May 1 '18 at 9:31
  • Install with sudo apt install xserver-xorg-video-intel – sudodus May 1 '18 at 9:33
  • 1
    @sudodus xserver-xorg-video-intel already installed – d a i s y May 1 '18 at 9:34
2

For Ubuntu 18.04, to resolve the issue, I have disabled Wayland in GDM3.

sudo vi /etc/gdm3/custom.conf

Change #WaylandEnable=false to WaylandEnable=false and reboot the system.

This can be done in either of the following ways,

  1. Choose recovery mode, from advance option in grub menu and drop to root shell to modify file /etc/gdm3/custom.conf.
  2. Set nomodeset to login,and follow the above steps. (In my case, I've already set.)
  3. With live dvd or bootable media: make sure the path of your installed drive /media/ubuntu/XXX/etc/gdm3/custom.conf which can be found with df -h

UPDATE:

It seems like this bug has been fixed with upgrading mutter package, so if the above solution did not work out, try to upgrade mutter package or install Ubuntu 18.04.2 or if you have installed 18.04 then upgrade it with sudo apt update && sudo apt upgrade.

If Ubuntu 18.04.2 is installed, then there is no need to disable Wayland.

  • If you need to boot with Live-CD/USB to edit that file, remember to edit the file installed on the hard drive, something like: Files - Other Locations - NN GB file system - Ctrl+Alt+T - sudo gedit /media/ubuntu/blah/etc/gdm3/custom.conf – Randall Whitman Sep 12 '18 at 2:50
0

I had the same problem. I tried a fresh install of Ubuntu 18.04 on a Dell Latitude D620, it booted fine from USB drive but after restart it just showed the ubuntu logo and the mouse cursor, but the system was not responding to CTRL+F2/F3 or mouse movements.

My hardware:

lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
Subsystem: Dell Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [1028:01c2]
Kernel driver in use: i915

So adding nomodeset to /etc/default/grub the system was able to boot I was stuck with the wrong resolution of 1024x768 instead of the 1280x800. So it is not a solution I wanted to live with.

Finally I found a good work around:

sudo apt-get install lightdm

Installing lightdm as Display Manager instead of the default gdm3 solved the problem with the Intel 945GM (i915) and the frozen ubuntu logo.

P.S.: WLAN was also not working with the integrated Broadcom BCM4311.

lspci -vnn | grep 14e4 
09:00.0 Ethernet controller [0200]: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCI Express [14e4:1600] (rev 02)
0c:00.0 Network controller [0280]: Broadcom Limited BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Solution was installing the firmware-b43-installer (https://askubuntu.com/a/609420/127023).

  • What solution of WLAN has to do with this login issue? – d a i s y Jan 23 at 4:35
0

Update: I switched to Unity after lightdm+Gnome was crashing (*)

I had the same problem with i915 module. The screen was freezing when booting after the cursor was appearing on the screen. It was solved by replacing gdm by lightdm as described above. Summarizing the recipe:

  1. Boot by adding the nomodeset option:

    a. Hold SHIFT to see GRUB menu before booting
    b. Press e and add nomodeset at the line
    linux /boot,vmlinuz-.... root=UUID=... ro quiet splash nomodeset and then press F10 to reboot.

  2. Start with low resolution screen with the above mentioned results.
  3. Install lightdm+unity desktop and choose it as default.
    sudo apt-get install lightdm; sudo apt-get install ubuntu-unity-desktop
  4. Reboot.

(*) i915 module error messages from dmesg, the session was forcingly logging out

  • Installing lightdm is workaround, not a solution. What if one wants to use gdm3 which is already default in 18.04? – d a i s y Jan 23 at 4:33

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.