14

My PC with Ubuntu 18.04 keeps freezing randomly. I know, it's very often topic. I've tried multiple nvidia-xxx versions, with no luck.

ubuntu-drivers devices

  • == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
  • modalias : pci:v000010DEd00000611sv00001458sd00003468bc03sc00i00
  • vendor : NVIDIA Corporation
  • model : G92 [GeForce 8800 GT]
  • driver : nvidia-304 - third-party free
  • driver : nvidia-340 - distro non-free recommended
  • driver : xserver-xorg-video-nouveau - distro free builtin

Last time it worked with Ubuntu 16.04 + nvidia-304_304.135. After upgrade do to 17.10 it was freezing too. Upgrade to 18.04 did not helped either.

nvidia-304_304.135 - old

  • does not boot to login screen
  • it's in black screen loop (some booting text is shown, but refreshed every 3 seconds)

nvidia-304.137 - third-party free

  • it's the same as 304.135

nvidia-340 - distro non-free recommended (ubuntu-drivers autoinstall)

  • freezing (even 2 times, when I wrote this question)
  • rendering works nice and smooth

xserver-xorg-video-nouveau - distro free builtin

  • does not freeze
  • it has terrible slow rendering

nvidia-390 (from ppa:graphics-drivers/ppa)

  • does not seems to work, because it's slow as nouveau

I don't need nvidia driver, I can live with nouveau (with repaired rendering). Any tips to how to get further? (repair nouveau rendering or get non-freezing driver working?)

  • Have you purged nouveau when you install the nvidia drivers? – Daniele Gamba May 1 '18 at 8:30
  • 1
    I've added /etc/modprobe.d/blacklist-nvidia-nouveau.conf with content "blacklist nouveau options nouveau modeset=0". It should be the same, but I will try to purge it too. – iki May 1 '18 at 9:59
  • Tried that and it's the same - slow rendering. And the software center sais something like "Custom manual driver installed". – iki May 1 '18 at 18:32
  • I have the same issue except my workstation will freeze and become unresponsive. I cannot even ALT-F3 to a terminal window. However, I can go to another PC and ssh into my workstation. But a reboot is all that will fix it. – Van Jun 11 '18 at 14:41
1

I was having laggy video performance in VLC and Chrome. I was running Nvidia 390.30 drivers. I tried other suggestions on other threads, but ultimately updating to Nvidia 390.48 drivers fixed my laggy video.

In Ubuntu 18.04 using this command with install the Nvidia 390.48 drivers:
sudo ubuntu-drivers autoinstall

Either uninstall all others, or use the Software & Update app to switch.

|improve this answer|||||
  • I've tried that earlier - it does not help. – iki Jun 11 '18 at 3:11
  • Maybe also this could help? sudo apt install nvidia-prime && sudo prime-select intel – Pablo Bianchi Oct 16 '18 at 3:09
0

I have a very strange solution which worked for me. Download nvidia driver as .run file from nvidia website. Run it as root, it will propose you to disable nouveau by wrting some file to modprobe. Accept it and reboot. Then use apt-get to install something like nvidia-driver-410 (or what have you).

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.