0

I am using IBus for pinyin in Ubuntu 18.04 (Gnome), with the "intelligent pinyin" input method.

The Chinese characters in the preview box are way too small and barely legible, i.e.:

enter image description here

What I tried:

~$ ibus-setup
~$ # I ticked option "Use custom font" and set very large font size
~$ ibus restart                        # (rebooting the machine also has no effect)

This did not change the font of the characters in the preview box.


NOTE (not a duplicate): the troubleshooting I followed is similar to the one proposed here for a previous version of Ubuntu (11.10). The approach described in the previous Q/A does not seem to be valid any longer, so I made a new question because this issue deserves some renewed attention. It is perhaps worth mentioning that the same troubleshooting was working on the most recent Linux Mint+Cinammon release, so the issue seems to be related with Ubuntu+Gnome.

  • Have you checked out if that method to increase the font size is effective with some other input method, e.g. ibus-sunpinyin? – Gunnar Hjalmarsson May 1 '18 at 22:29
  • @GunnarHjalmarsson I tried several ones for Chinese language, and all of them display the same font size for the preview box. Actually, I suspect that ibus-setup configuration is not really being used by the OS, since when I add some new input-method through system settings this is not listed under ibus-setup. The thing is, system settings does not show any option to change the font size AFAIK. – Patrick Trentin May 1 '18 at 22:54
2

I found this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1409121

with the advice to install this extension:

https://extensions.gnome.org/extension/1121/ibus-font-setting/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.