10

I installed Ubuntu 18.04 64-bit and enabled DRM in Firefox. When trying to watch Netflix, I get the following errors:

Oops, something went wrong...

Netflix video player unavailable

We're having trouble playing Netflix in your browser. Please make sure you're on an official version of Firefox.

Error Code: F7355-1204

I'm using the version of Firefox that came installed with Ubuntu. How do I play Netflix videos on 18.04?

  • Do you have Adobe Flash? Can you watch videos from Facebook? – Dawid Laszuk May 1 '18 at 6:40
  • In theory you should already be able to do so. If no one comes up with a better answer you could try reinstalling firefox, but I'd wait to see if someone has a less drastic solution. – dsSTORM May 1 '18 at 6:41
  • 1
    I don't have Flash and didn't have in 17.10, but in 17.10 Netflix worked. – SurvivalMachine May 1 '18 at 6:57
  • @SebastianStark That fixed the issue, thanks! Please post it as an answer and I'll accept it. – SurvivalMachine May 1 '18 at 7:33
11

In order to watch netflix with firefox under Ubuntu 18.04, you need to make sure that you have DRM enabled in your firefox settings (Go to settings, scroll down, check play drm-controlled content). Also make sure you have the libavcodec-extra package (from the universe repository) installed. In order to install libavcodec-extra you should have the universe repository enabled:

sudo add-apt-repository universe

Then install the libavcodec-extra package:

sudo apt install libavcodec-extra
0

I found this fix at https://help.netflix.com/en/node/23742. I have the HTML 5 theme enabled and silverlight theme was also added but not enabled.

I also have the following plugins enabled, OpenH264 Video Codec, shockwave flash, and Widevine Content Decryption Module.

Netflix is now working perfectly from firefox browser in ubuntu 18.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.