8

I have a problem when logging on when I turn on my PC. If I enter my password correctly, it starts without problems. But if I enter my password incorrectly and then I enter it correctly, it does not show me the desktop, the screen only shows the wallpaper.

I would also like to know if the error only happens to me, or also to you. I just installed Ubuntu.

1
  • I have the same problem, I found a walk around: when I press alt + ctrl + F2 then alt + ctrl + F1 I can reenter my passowrd and log in. Commented May 14, 2018 at 7:41

3 Answers 3

5

This is a known bug that's listed in the release notes. This bug affects me, please click the button at the top of the bug to say that it affects you too. The workaround is to click Cancel after entering an incorrect password and then to re-enter your password. Also, if you are able, please keep an eye on this bug and help GNOME get the logs they need to fix the issue! :)

2
  • 1
    Those bugs are all about entering a wrong password. I have the same behaviour (the beaver background with a mouse cursor but nothing else, can't even move the mouse) but without entering a wrong password (at least, not since the latest reboot).
    – Adeynack
    Commented May 9, 2018 at 10:38
  • Try filing a bug for that @Adeynack but say in the description that it's not a duplicate of bug 1766137 because it's not a bug after entering the wrong password.
    – Ads20000
    Commented May 10, 2018 at 12:58
4

I personally solved (or worked around) the problem by clicking on the gear on the password screen and selecting Ubuntu on Wayland instead of Ubuntu (on classic X). The bug is not present in my case with Wayland.

1
  • Thank you! This actually solved the problem witha login loop on ubuntu 18.04!
    – Joeppie
    Commented Sep 14, 2018 at 12:11
1

I fought with this on and off for a few days after upgrading from 16.04 to 18.04. What a pain!

So, the extended story here is that Ubuntu switched to a "Wayland" desktop in this release, rather than continuing to use "Xorg". Then, after a "failed experiment" with that, they switched back! Personally, I upgraded again to 18.10, hoping that would magically fix it, since they began the trek back to XOrg as the default, but no luck...

If you follow the post of @Adeynack, you can most likely start Ubuntu by choosing the "Wayland" option at the login screen via the gear. That worked for me. (At first, I was terrify that my credentials didn't work at all, and I was locked out of my machine. Thank god that wasn't the case!) You may well find, however, that all of your XOrg options (i.e. "Ubuntu", "Mate", etc.) will silently fail and loop you back to the login.

This might be good enough for many of you. But, it was not for me, because native screen sharing over VNC doesn't work! In fact, I read that hardly any of the third party screen sharing utilities work on Wayland either, or they have problems at best.

After a lot of Googling and fiddling... I fixed this Xorg issue on my machine by editing a basic XServer config file:

sudo vi /etc/X11/Xwrapper.config

Here I found this text:

allow_users=anybody
allowed_users=console

Apparently, allow_users is not a valid key (who knows how it got there!), so I simply changed it to this:

allowed_users=anybody
allowed_users=console

Viola! The XOrg options worked after that! I went with the new default "Ubuntu" choice, which is what I'd recommend if you don't know which option to choose.

Next, as you'll find in other places online, you might want to entirely disable Wayland. Open the boot config which controls that:

sudo vi /etc/gdm3/custom.conf

In the [daemon] section, uncomment WaylandEnable=false. Now, you'll not even have the Wayland desktop option, and you'll be living back in pure XOrg land again.

Finally, I found that when I made the switch back to XOrg all my icons looked funky. It turns out that is just the new standard theme / icon set using "Yaru". Well, I didn't like it. If you search for "GNOME Tweaks" in the Activities search (and install the app if you don't have it), then choose "Appearance", you'll be able to switch back to "Unity" icons, or select from a solid collection of others, plus more extended options to alter the UI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .