3

In Gnome I can have a fixed number of workspaces. As I have ten number keys, I have created ten workspaces. So I want Super+1 to switch to workspace 1, Super+2 to switch to workspace 2 and so on. I can acchieve this by running the following command for each workspace:

dconf write /org/gnome/desktop/wm/keybindings/switch-to-workspace-1 "['<Super>1']"

This works for all 10 workspaces.

Now, similar, I want to assign Super+Shift+1 to move the current window to workspace 1. So I tried the following command for each workspace:

dconf write /org/gnome/desktop/wm/keybindings/move-to-workspace-1 "['<Shift><Super>exclam']"

This works fine for workspaces 1-6. Starting with workspace 7, Super+Shift+7 or <Shift><Super>slash (German keyboard) does not trigger anything - though if I assign it to another action the keyboard shortcut works.

How can I enable the move-to-workspace keyboard shortcuts for workspaces with numbers greater than 6?

0
  • Add a new custom shortcut

    GNOME - New shortcut

  • Use xdotool. In the command line put "xdotool getactivewindow set_desktop_for_window 8" to send your window on the workspace 9 (there is a -1 delta to take into consideration with xdotool).

    GNOME - Setting  the command called by the shorcut

  • This sends the window to the desired workspace but doesn't switch the view to it. Personally, I prefer to have another shortcut to move to the workspace (xdotool set_desktop 8).

Hope this help!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.