2

This happens on both my desktop and my laptop.

There's an issue detecting USB installers on distros newer than 16.04 when using USB 3.0+ ports and USB 3.0 installation media.

It's related to the USB controller not detecting the live installation media even after successfully booting into the USB device from BIOS.

Regardless if the USB is plugged into a 2.0 or 3.0 port and whether or not the USB key is 2.0 or 3.0.

If your BIOS is unable to disable 3.0 USB support then you're out of luck except for the final workaround below.

5

Here's a set of potential fixes:

  • Change the boot mode to AHCI
  • hit X at the GRUB bootloader screen and change live splash to nomodeset
  • If it's a USB 3.0 USB make sure you use a USB 3.0 port
  • If the USB 3.0 USB isn't working - try a USB 2.0 port
  • If that still doesn't work - try a USB 2.0 key in a USB 2.0 port
  • If you have no USB 2.0 ports try going into the BIOS and disabling USB 3.0 at the BIOS level
  • If your BIOS doesn't have that setting try using a USB extension cable to downgrade the link to USB 2.0
  • If you can't do any of that, then congratulations you're just as stuck as I was for many many hours

Finally if none of those work, then you can try an answer I found after a ton of digging located here:

https://askubuntu.com/a/946334/85384

In essence, when it looks like Ubuntu is waiting for the USB stick to be present to read from you can unplug the USB stick and replug it back into the same slot. This fixed the issue for me 100%.

  • In my case I needed two things: 1. to wait for the "Set SEL for device-initiated U2 failed" message (but not much longer) 2. to unplug the USB stick and then to plug it back but through the USB extension cable. Without that trick I was ending up with a black screen. – Przemek Pokrywka Nov 27 '19 at 12:23
2

Just yesterday encountered the same problem and nothing worked for me. I updated BIOS, then downloaded latest ISO with Ubuntu, used USB creator to make a loading USB, instead of install Ubuntu chosed "Try Ubuntu without installing", then installed Ubuntu using desktop icon there.

1

Tired everything, nothing helped. Lost 4 hours. As a desperate move I switched hdmi cable from RX 570 to integrated graphics and BINGO! Some sources suggested graphics

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.