I am Using Ubuntu in Virtual Box.. the Host OS is Windows10 with dedicated intel's Graphics.

I have reinstalled twice, probably this starts due to sudden shutdown or some reason. Dnt know whats the problem.

Saw a old post about this type on Ubuntu 12.04 / 14.04 LTS ... but their problem/ solution was on Nvidia Driver. And following that didnt help me! . Any solution ?

  • 1
    One more thing, i have the 18.04 live server one for a while .... this happens with it too...... but reason dnt know Apr 30, 2018 at 16:02
  • 1
    Same here. Virtualbox 5.2. Ubuntu 18.04. Windows 10 Host with Intel graphics. Reinstalled thrice. Fails on bootup. No error, it simply waits with a purple screen and 5 dots. No guest additions, it is a fresh install. Trying to login the first time after reboot. Based on the answers, it seems there is no single reason. Jul 13, 2018 at 15:26
  • 1
    I gather that currently (windows 10 v 2004 Virtualbox 6.1) VirtualBox doesn't work alongside WSL2 b/c of the bugs in VBox support for Hyper-V. stackoverflow.com/questions/62184881/virtualbox-and-wsl2 see also docs.microsoft.com/en-us/windows/wsl/… Aug 4, 2020 at 21:51
  • It is also possible that a windows update changed some settings. Verify hyper-v is disabled and sandbox as well (found in the features part of windows)
    – FrankIJ
    Oct 6, 2020 at 13:18
  • I downloaded the xubuntu torrent and also on same problem. The guest Xubuntu hangs during the boot. Virtualbox 6.1.16 r140961 (Qt5.6.2).
    – cavila
    Jun 28, 2021 at 0:45

11 Answers 11


i've had the same issue:

  • 3D acceleration = off
  • 10 GB Ram

My solution was:

  • 1 processor => 4 processors
  • enable PAE/NX
  • 11
    I also had to increase the number of processors (I set it to 2). Enabling PAE/NX was not necessary for me.
    – Ignitor
    Jun 9, 2018 at 13:12
  • Same findings as @Ignitor Jun 29, 2018 at 14:29
  • @Ignitor worked for me too.. i.e. 2 seemed to suffice
    – bph
    Jul 6, 2018 at 8:34
  • 1
    Adding +1 CPU worked for me.
    – Kladskull
    Jul 6, 2018 at 18:06
  • scratch that - still not working for me, well it seems to not freeze randomly once in a blue moon
    – bph
    Jul 9, 2018 at 11:29

Several of my old VMs seem to hang on bootup. If in Grub I select "recovery mode", the last messages displayed on the screen are:

smp: Bringing up secondary CPUs...
x86: Booting SMP configuration:

Then it hangs.

In my case, I can confirm that for all my VMs experiencing this problem, changing the Virtualbox setting "System -> Acceleration -> Paravirtualization Interface" from "Legacy" to "Default" enabled these old VMs to work again. Switching it back to "Legacy" immediately makes it hang on boot, so I know for certain this is the key to the issue in my case.


In the VirtualBox machine settings, simply turn off the "3D acceleration".

  • 6
    I already had 3D acceleration turned off, but I did increase the video memory from 16 to 64 Mb and that got it to work for me. May 8, 2018 at 13:57
  • i have kept my Vid memory full -_- @Chris Chubb May 9, 2018 at 6:10
  • It was already off for me. Adding a second cpu per bressers answer did the trick.
    – Dave
    Jul 5, 2018 at 15:03
  • Worked for me also. Jun 26 at 5:58

Did you allocate enough RAM to the virtual machine? Give it 2GB or more RAM. I discovered when I ran Ubuntu 18.04 live cd on virtual box, it froze at some point, but on allocation of more RAM, I got it working perfectly

  • i gave it 4 GB ram .... and 2 core to process from the start .... Turning off the 3d acceleration ... the problem is not repeating now !!! May 1, 2018 at 5:49

I had the same problem. When I experienced the problems my settings were:

  • RAM 4GB
  • CPU 3
  • PAE/NX Enabled
  • VT-x/AMD-V Enabled
  • Nested Paging Enabled
  • 3D Acceleration Disabled
  • 2D Video Acceleration Disabled

I changed the following settings:

  • CPU 1
  • PAE/NX Disabled

That made it work.

I changed the following setting:

  • PAE/NX Enabled

It still worked.

Looked like there is 'something' with the number of processors. Based on the other answers, there does not seem to be a 'right' number that works for every system.

I then realized that I also have an Ubuntu 18.04 Server VM on my system. This one still works. I noticed that for this virtual machine the Paravirtualization Interface is set to Default, while for my Desktop VM (the one I was having problems with), it was set to Legacy. I changed it to Default and now it works, with any number of CPU's.

So the solution, for me, was to:
Set Paravirtualization Interface to Default.


For me, I had to disable hyper-v before I could get it to work. Increasing the other options listed in this answer didn't help. This can be done by searching for "Turn windows features on or off" in Windows, then un-checking Hyper-V (you need to restart your computer after).

  • I was installing Ubuntu Server and your answer helped. A detailed ans is here.
    – VivekDev
    Apr 1, 2020 at 5:10

I had a similar problem and this is what I did to fix it.

Essentially changed the graphics controller from VMSVGA to VBoxSVGA. My 3D acceleration is still on and I have video memory at 128 MB.

See here for the difference between the different graphics controllers.

  • 2
    Adding video memory and making it 128 MB helped to fix my screen issue Dec 14, 2019 at 1:52

Was freezing on "Booting smp configuration" after upgrading to 18.04 / Kernel on Virtualbox 5.2.18

Had to go to VM Settings -> System > Acceleration > Paravirtualization Interface -> Default (Was "legacy" before).

3D acceleration is enabled and working (Make sure to install guest additions to make it run smoothly)


I am using Virtual Box 5.2.20 and Ubuntu 18.04.1. I was trying to install Ubuntu and it was painfully slow to boot and log showed guest would become unresponsive every few seconds. What finally worked for me was to change the paravirtualization to legacy in order to complete the install. Then the guest would hang on start up. I had to change the paravirutalization mode back to default in order to successfully boot.


It seems like there is no definite answer to this one.

What worked for me is - Uncheck the box labelled "Solid-state Drive" for the virtual hard disk.

3D acceleration is Enabled. 128 MB Video Memory. 4 GB RAM. 2 CPU. Virtualbox Guest Additions are Not installed. All other system settings are at default.

  • Hi Runtime! Can you explain why disabling the Solid-state Drive ? It's common that the 3d-acceleration can cause freezing.
    – abu_bua
    Jul 13, 2018 at 16:22
  • Select your VM in manager > Settings > Storage > Select your VDI under SATA > Uncheck the Solid-state Drive box. It is disabled by default. I have an SSD so I had enabled it. Apparently, it is for the guest to see it as an SSD. Seems like there is a bug in Virtualbox 5.2.14 and/or Ubuntu 18.04 where it cannot handle SSD properly. Jul 13, 2018 at 16:37

The only thing that worked for me:

Increase "Video Memory" settings from 16MB to 128MB.

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.