Installed fresh 18.04 LTS. Everything works fine except the touchpad. Thinkpad has touchpad buttons above it and they work fine, but the buttons under touchpad at the bottom only work as one left click. There is no option in settings to change that, it did work on Fedora 27 though. Is there anything I can change to add this funcionality? I tried THIS Touchpad right click doesn't work on touchpad, only the buttons above it. Thinkpad E480 Ubuntu 18.04 LTS, but had no success.

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

Also, i tried to do same with gnome tweaks, but that didn't help aswell. Is there anything else i can do?

  • Did you modify any of your xorg.conf.d files or install any synaptics drivers? What is the output of the command: "ls /usr/share/X11/xorg.conf.d/" ? – PatKilg Apr 30 '18 at 14:35
  • @PatKilg, i didn't modified any of those files. The output is: 10-amdgpu.conf 10-quirks.conf 10-radeon.conf 40-libinput.conf 70-wacom.conf – Anton Mashkin May 1 '18 at 1:50
  • Hmm. I think I made an assumption here. Please let us know the exact model of thinkpad. sudo dmidecode -t system | grep Product should get you there. – PatKilg May 2 '18 at 0:16
  • @PatKilg it's Thinkpad 13 2017 Output is: Product Name: 20J10021UK – Anton Mashkin May 2 '18 at 1:20

Install and open gnome-tweak and go to Keybord & Mouse >>> mouse click emulation and just click on Area and close the window.

enter image description here

| improve this answer | |
  • I already tried that as i mentioned at bottom of my question. By the way i have feeling that those setting doesn't work at all, because with any of those selections touchpad still works same(fingers mode). – Anton Mashkin May 1 '18 at 1:59
  • It may be considered as a worked around, however it is not solving actual problem. – g_p May 1 '18 at 13:22
  • For some reason, on second try this worked! Thank you! – Anton Mashkin Sep 13 '18 at 14:22
  • The "area" option works great on my Lenovo ideapad 330S-15IKB with Ubuntu 18.10. The user must logout or reboot Ubuntu for the change to take effect. This option is so much nice than the two-finger tap. – Andrew Jan 28 '19 at 3:54

i faced the similar problem after doing the changes as described above using the gnome tweaks, if it doesn't work try doing this: click on settings in ubuntu--->click on devices---> mouse and keyboards---> set primary button to left

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.