2

inb4 duplicate: yes there are many similar questions, but they are either about mouse-acceleration in general instead of specifically touchpad related or their answers didn't solve my problem.

I have tried:

  • gnome-tweaks lets me set the acceleration profile for mouse to "flat", but not for touchpad.
  • dconf-editor also provides this option for trackballs, but still not for touchpads.
  • editing /usr/share/X11/xorg.conf.d/90-mouse.conf as proposed here has no effect
  • xset m 0 0 has no effect

I am using ubuntu 18.04 but I had the same problem on 17.10 as well

0

We will use SynapticsTouchpad and synclient AccelFactor=0 command to solve it.

  1. If you don't have SynapticsTouchpad and synclient command does not work, then install SynapticsTouchpad(If you already got it go to step 2).

    1.1 Open Terminal (Ctrl+Alt+T or Super(Win) key => Terminal)

    1.2 Install SynapticTouchpad

    sudo apt install xserver-xorg-input-synaptics

    1.3.1 Enable SHMConfig

    sudo gedit /etc/X11/xorg.conf"

    1.3.2 Paste this into the document and save the document:

    Section "InputClass"
        Identifier "enable synaptics SHMConfig"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
    EndSection 

    1.3.3 Close the document, reboot your system.

  2. Open Terminal and type

    synclient AccelFactor=0

Tested in Ubuntu 18.10 a few hours ago. Everything fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.