10

I am able to mount ntfs drives automatically using Disks app in Ubuntu 18.04 LTS. However, I am unable to write to the NTFS partions.

Below are my ntfs partions as per Disks app.

  • /dev/sda3 (/dev/disk/by-uuid/162451E92451CC7D)
  • /dev/sda4 (/dev/disk/by-uuid/B696F3C596F38461)

Is there are GUI based solution for enabling NTFS write support?

Why isnt it enabled by default?

My FSTAB file

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=016b0523-a020-4f98-b7de-fffdb7b39b0d /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=3026-A145  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/sda9 during installation
UUID=689f530e-afea-43e5-b55e-6743633d2fe9 /home           ext4    defaults        0       2
# swap was on /dev/sda8 during installation
UUID=e9eb9e5d-6f45-4054-ad01-94a8b8c9df45 none            swap    sw              0       0
/dev/disk/by-uuid/162451E92451CC7D /mnt/162451E92451CC7D auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/B696F3C596F38461 /mnt/B696F3C596F38461 auto nosuid,nodev,nofail,x-gvfs-show 0 0

EDIT

Adding out of mount command as requested by @mook765

~$ mount | grep sda4
/dev/sda4 on /mnt/162451E92451CC7D type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096,x-gvfs-show)
~$ mount | grep sda3
/dev/sda3 on /mnt/B696F3C596F38461 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096,x-gvfs-show)
8
  • 1
    The files in /dev/disk/by-uuid are links to /dev/sdXY. You can check this in Nautilus to see to which partitions the last two lines in your fstab point. – mook765 Apr 30 '18 at 8:15
  • Thanks. I checked and figured out that /dev/disk/by-uuid are the ntfs partitions. HOw do I enable write support? – GeorgeOfTheRF Apr 30 '18 at 8:44
  • You can see how the partition sda3 is currently mounted with mount | grep sda3. I guess it will show you the partition is mounted read-only, probably due to Window's fast startup feature. – mook765 Apr 30 '18 at 9:00
  • Window's fast startup feature is already disabled but still unable to write. Should I update the fstab to make is work? – GeorgeOfTheRF Apr 30 '18 at 9:03
  • 1
    sda3 is mounted read-only, that shouldn't be the case. I think the reason is a corrupted file-system on sda3. You should run a file-system-check on this partition from within Windows. helpdeskgeek.com/how-to/run-chkdsk-utility-xp . Can you write to the other partition (sda4)? – mook765 Apr 30 '18 at 20:41
20

to mount the partitions in read-write mode:

run ntfsfix /dev/sdaX to resolve the problem. then remount the partitions.

5
  • Thanks! Is this a permanent fix or should I do it every time I reboot? – GeorgeOfTheRF Apr 30 '18 at 14:53
  • 6
    always reboot from windows. do not shutdown. this releases the windows ntfs volumes – kishea Apr 30 '18 at 14:56
  • This isnot working – GeorgeOfTheRF Apr 30 '18 at 18:29
  • 1
    sdaX where X is 1,2,3,4. Generally the partition number in question. thanks – kishea Oct 23 '18 at 9:19
  • 1
    thanks, for me it was sudo ntfsfix /dev/nvme0n1p4 – Gabriel Fair Feb 13 '19 at 23:00
0

If you're dual booting Linux with Win 8.1 or Win 10, Linux will not allow you to mount an ntfs partition in write mode, unless you've disabled Fast Boot in windows first (the link is a guide for Win8.1 but identical in Win10).

Disabling Fast Boot has solved this problem for me on a dual boot machine, originally using Win8.1 then Win10, and with Ubuntu 14.04 & 20.04. I assume it applies generally to any Linux that supports NTFS and to all Windows post-Win8.1 RTM, when Fast Boot was introduced.

(The OP had disable Fast Boot, so must have had another problem. Nonetheless, this solution should work for others who end up here.)

ntfsfix is NOT a solution Reason: If you have not disabled fast boot, when you leave Windows, it only shuts your applications, then it hibernates some aspects of the OS itself for a speedy restart, and flags its NTFS partitions as locked. When you next reawaken Windows, it will check that all its ntfs disks are unchanged. In the interim, if you've booted Linux and written to any of the ntfs partitions with ntfsfix, then the next time you return to Windows, it will believe the disk has been corrupted.

Here's a useful tutorial about this problem and solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.