0

I tried to install Bionic server as a guest on XenServer 7.0. After booting the iso I get a black terminal saying:

vbd vbd-5696: 19 xenbus_dev_probe on device/vbd/5696

And that's it. Did anyone have more success or can point me to a way to resolve this?

  • There seems to be no internet-available information on Ubuntu 18.04 and Xenserver, probably because it is not a supported guest OS. – G Koe May 30 '18 at 22:50
  • Ubuntu 18.04 IS now supported on Xenserver 7.6CR. See updated answer. – G Koe Oct 8 '18 at 23:34
2

UPDATE: Ubuntu 18.04 IS supported on Xenserver 7.6CR see release notes here: here: https://docs.citrix.com/en-us/xenserver/current-release/whats-new.html

and Supported Guest Operating Systems updated August 15th.

Ubuntu 18.04 is still not a supported guest on Citrix Xenserver 7.0, and it isn't even a supported guest on Xenserver 7.5CR as of May 2018. So, Your Mileage May Vary.

This fellow has successfully installed the 18.04 Server (liveCD version) on an unknown version of xenserver, but his notes are vague.

You can get it to boot in Xenserver by choosing EDD=on and nolapic from the installer boot parameters by pressing F6 at the first boot screen. What do these options do? There's a great explanation here.

Reference:

If you edit the installer boot entry and remove quiet splash --- you will likely see a kernel boot messages like:

BIOS EDD facility v0.16 2004-June25, 0 devices found

EDD information not available.

....just before the booting stops.
Please note that the VM doesn't hang or crash, it just waits forever.

I found that the ubiquity installer hangs at the start of "Copying Files" and does not continue.

Attempts to install Ubuntu server 18.04 also required EDD=on and nolapic, and although the install was successful, the first boot required adding EDD=on and nolapic to the kernel parameters, and once booted network adapter was unable to communicate.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.